Browse Source

Removed fuzzy dependencies.

Fuzzy dependencies tend to be a little brittle, as breaking changes
could be introduced that engineers are not aware of. This locks
down the versions used in this project's npm dependencies. (The
bower dependencies didn't need them).

Change-Id: I5bacb62a724b803926aa16859e536b15a74d40c1
changes/64/192364/1
Michael Krotscheck 4 years ago
parent
commit
3148fc8903
1 changed files with 11 additions and 11 deletions
  1. 11
    11
      package.json

+ 11
- 11
package.json View File

@@ -4,8 +4,8 @@
4 4
   "private": true,
5 5
   "devDependencies": {
6 6
     "bower": "1.3.12",
7
-    "grunt": "^0.4.5",
8
-    "grunt-bower-task": "^0.4.0",
7
+    "grunt": "0.4.5",
8
+    "grunt-bower-task": "0.4.0",
9 9
     "grunt-cli": "0.1.13",
10 10
     "grunt-connect-proxy": "0.1.11",
11 11
     "grunt-contrib-clean": "0.6.0",
@@ -19,20 +19,20 @@
19 19
     "grunt-shell": "1.1.1",
20 20
     "grunt-usemin": "2.4.0",
21 21
     "grunt-webfont": "0.4.8",
22
-    "grunt-contrib-concat": "^0.5.1",
23
-    "grunt-contrib-uglify": "^0.8.1",
24
-    "grunt-karma": "^0.10.1",
22
+    "grunt-contrib-concat": "0.5.1",
23
+    "grunt-contrib-uglify": "0.8.1",
24
+    "grunt-karma": "0.10.1",
25 25
     "jasmine-core": "^2.2.0",
26
-    "karma": "^0.12.31",
27
-    "karma-chrome-launcher": "^0.1.7",
26
+    "karma": "0.12.31",
27
+    "karma-chrome-launcher": "0.1.7",
28 28
     "karma-cli": "0.0.4",
29
-    "karma-jasmine": "^0.3.5",
30
-    "karma-phantomjs-launcher": "^0.1.4",
31
-    "karma-ng-html2js-preprocessor": "~0.1"
29
+    "karma-jasmine": "0.3.5",
30
+    "karma-phantomjs-launcher": "0.1.4",
31
+    "karma-ng-html2js-preprocessor": "0.1"
32 32
   },
33 33
   "main": "Gruntfile.js",
34 34
   "dependencies": {
35
-    "grunt": "^0.4.5"
35
+    "grunt": "0.4.5"
36 36
   },
37 37
   "scripts": {
38 38
     "postinstall": "bower install",

Loading…
Cancel
Save