Browse Source

Merge "Revert "Requirements on cliff-tab is replaced with cliff requirement.""

tags/11.0.0
Jenkins 2 years ago
parent
commit
c248175b51
5 changed files with 5 additions and 5 deletions
  1. 1
    1
      Dockerfile
  2. 1
    1
      Vagrantfile
  3. 1
    1
      debian/control
  4. 1
    1
      requirements.txt
  5. 1
    1
      specs/network-checker.spec

+ 1
- 1
Dockerfile View File

@@ -3,7 +3,7 @@ ENV ARCH amd64
3 3
 ENV DIST trusty
4 4
 RUN echo 'deb http://fuel-repository.mirantis.com/fwm/5.0/ubuntu trusty main' >> /etc/apt/sources.list
5 5
 RUN apt-get -q update
6
-RUN apt-get -y --force-yes install cliff python-pyparsing python-pypcap scapy python-pip wget openssh-server
6
+RUN apt-get -y --force-yes install cliff-tablib python-pyparsing python-pypcap scapy python-pip wget openssh-server
7 7
 RUN pip install pytest mock
8 8
 RUN sudo locale-gen en_US.UTF-8
9 9
 

+ 1
- 1
Vagrantfile View File

@@ -17,7 +17,7 @@ Vagrant.configure(VAGRANTFILE_API_VERSION) do |config|
17 17
     config.vm.network :private_network, ip: '10.200.0.0', type: 'dhcp'
18 18
     config.vm.provision :shell, :inline => "echo 'deb http://fuel-repository.mirantis.com/fwm/5.0/ubuntu trusty main' >> /etc/apt/sources.list"
19 19
     config.vm.provision :shell, :inline => "sudo apt-get update"
20
-    config.vm.provision :shell, :inline => "sudo apt-get -y --force-yes install cliff python-pyparsing python-pypcap scapy python-pip vde2"
20
+    config.vm.provision :shell, :inline => "sudo apt-get -y --force-yes install cliff-tablib python-pyparsing python-pypcap scapy python-pip vde2"
21 21
     config.vm.provision :shell, :inline => "sudo pip install pytest mock"
22 22
     config.vm.provision :shell, :inline => "cd /vagrant && sudo python setup.py develop"
23 23
   end

+ 1
- 1
debian/control View File

@@ -12,7 +12,7 @@ Package: network-checker
12 12
 Replaces: nailgun-net-check
13 13
 Conflicts: nailgun-net-check
14 14
 Architecture: all
15
-Depends: cliff,
15
+Depends: cliff-tablib,
16 16
          python-daemonize,
17 17
          python-netifaces,
18 18
          python-pypcap,

+ 1
- 1
requirements.txt View File

@@ -1,4 +1,4 @@
1
-cliff
1
+cliff-tablib
2 2
 scapy==2.2.0-dev
3 3
 pypcap==1.1.1
4 4
 stevedore

+ 1
- 1
specs/network-checker.spec View File

@@ -17,7 +17,7 @@ Requires: python-argparse
17 17
 Requires: vconfig
18 18
 %endif
19 19
 Requires:  python-pypcap
20
-Requires:  python-cliff
20
+Requires:  python-cliff-tablib
21 21
 Requires:  python-stevedore
22 22
 Requires:  python-daemonize
23 23
 Requires:  python-yaml

Loading…
Cancel
Save