Browse Source

Add Python 3 Train unit tests

This is a mechanically generated patch to ensure unit testing is in place
for all of the Tested Runtimes for Train.

See the Train python3-updates goal document for details:
https://governance.openstack.org/tc/goals/train/python3-updates.html

As per below ML thread, we are good to drop the py35
testing also:
http://lists.openstack.org/pipermail/openstack-discuss/2019-April/005097.html

[1] http://lists.openstack.org/pipermail/openstack-discuss/2019-April/004647.html
[2]
https://governance.openstack.org/tc/reference/runtimes/stein.html
https://governance.openstack.org/tc/reference/runtimes/train.html
Story: #2005924
Task: #34225

Change-Id: Ibdafaa8b7f946c99a9083874296df82921ad770b
stable/train
elajkat 2 years ago
committed by Lajos Katona
parent
commit
364dd0a3cf
  1. 2
      .zuul.yaml
  2. 2
      bindep.txt
  3. 2
      setup.cfg
  4. 2
      tox.ini

2
.zuul.yaml

@ -2,7 +2,7 @@
templates:
- check-requirements
- openstack-python-jobs-neutron
- openstack-python36-jobs-neutron
- openstack-python3-train-jobs-neutron
- build-openstack-docs-pti
check:
jobs:

2
bindep.txt

@ -5,4 +5,4 @@ mysql-client [platform:dpkg]
mysql-server [platform:dpkg]
postgresql
postgresql-client [platform:dpkg]
libpq-dev [platform:dpkg]

2
setup.cfg

@ -17,6 +17,8 @@ classifier =
Programming Language :: Python :: 2.7
Programming Language :: Python :: 3
Programming Language :: Python :: 3.5
Programming Language :: Python :: 3.6
Programming Language :: Python :: 3.7
[files]
packages =

2
tox.ini

@ -1,5 +1,5 @@
[tox]
envlist = py36,py35,py34,py27,pep8
envlist = py36,py37,py27,pep8
minversion = 2.0
skipsdist = True

Loading…
Cancel
Save