Browse Source

update requirements for neutron-lib 1.18.0

Neutron-lib 1.18.0 is our Rocky RC and is already being used by neutron
[1]. This patch updates the neutron-lib required version to match
neutron [1] in prep for the Rocky release.

It also adds a lower constraints zuul job to ensure neutron is pulled
into the env; otherwise the errors show in PS1 results will occur.

[1] https://review.openstack.org/#/c/583671/

Change-Id: I6b81670ade7131caedcc2c0b5dddff4415554676
stable/rocky
Boden R 4 years ago
parent
commit
58c500f642
  1. 10
      .zuul.yaml
  2. 2
      lower-constraints.txt
  3. 2
      requirements.txt

10
.zuul.yaml

@ -2,8 +2,14 @@
check:
jobs:
- networking-l2gw-tempest-dummy
- openstack-tox-lower-constraints
- l2gw-tox-lower-constraints
gate:
jobs:
- networking-l2gw-tempest-dummy
- openstack-tox-lower-constraints
- l2gw-tox-lower-constraints
- job:
name: l2gw-tox-lower-constraints
parent: openstack-tox-lower-constraints
required-projects:
- openstack/neutron

2
lower-constraints.txt

@ -50,7 +50,7 @@ munch==2.1.0
netaddr==0.7.18
netifaces==0.10.4
neutron==12.0.0
neutron-lib==1.13.0
neutron-lib==1.18.0
openstacksdk==0.11.2
os-client-config==1.28.0
os-service-types==1.2.0

2
requirements.txt

@ -4,7 +4,7 @@
pbr!=2.1.0,>=2.0.0 # Apache-2.0
Babel!=2.4.0,>=2.3.4 # BSD
neutron-lib>=1.13.0 # Apache-2.0
neutron-lib>=1.18.0 # Apache-2.0
python-neutronclient>=6.7.0 # Apache-2.0
ovsdbapp>=0.10.0 # Apache-2.0
neutron>=12.0.0 # Apache-2.0

Loading…
Cancel
Save