Browse Source

Use ensure_packages to install python3-redis

In the ceilometer manifest, we were using ensure_resource to make
sure the python3-redis package was installed when needed. However,
puppet-aodh changed to use ensure_packages with [1], which breaks
us. Moving to use ensure_packages as well.

[1] - https://review.opendev.org/c/openstack/puppet-aodh/+/789419

Change-Id: Id721cd84740adb9d459c1a5ad5cba919735b6f01
changes/35/789735/1
Javier Pena 3 months ago
parent
commit
33517d4b22
  1. 2
      packstack/puppet/modules/packstack/manifests/ceilometer.pp

2
packstack/puppet/modules/packstack/manifests/ceilometer.pp

@ -18,7 +18,7 @@ class packstack::ceilometer ()
$redis_port = hiera('CONFIG_REDIS_PORT')
$coordination_url = "redis://${redis_host}:${redis_port}"
ensure_resource('package', 'python-redis', {
ensure_packages('python-redis', {
name => "python${pyvers}-redis",
tag => 'openstack',
})

Loading…
Cancel
Save