Browse Source

Merge "Revert "Pin puppet_forge gem to version 2.2.6 for tests""

Zuul 8 months ago
parent
commit
6c8454d96b
1 changed files with 0 additions and 3 deletions
  1. 0
    3
      run_tests.sh

+ 0
- 3
run_tests.sh View File

@@ -256,9 +256,6 @@ if [ "${INSTALL_FROM_SOURCE}" = true ]; then
256 256
   export GEM_BIN_DIR=/tmp/packstackgems/bin/
257 257
   export PUPPETFILE_DIR=/usr/share/openstack-puppet/modules
258 258
   export GEM_HOME=/tmp/packstackgems
259
-  # puppet_forge 2.2.7 has a dependency on semantic_puppet ~> 1.0
260
-  # which is not compatible with dependency of latest r10k on semantic_puppet ~> 0.1.0
261
-  $SUDO gem install puppet_forge -v '= 2.2.6'
262 259
   $SUDO gem install r10k --no-ri --no-rdoc
263 260
   # make sure there is no puppet module pre-installed
264 261
   $SUDO rm -rf "${PUPPETFILE_DIR:?}/"*

Loading…
Cancel
Save