Browse Source

Use upper-constraints when installing packstack from source

Currently, it's not using the constraints file so we may use different
versions that other services.

Change-Id: I3f8eb965b6f08ddf6c0bc89a53e051e43047aecb
(cherry picked from commit 7417aef9bc)
changes/82/676382/3
Alfredo Moralejo 6 months ago
parent
commit
96fbb954ed
1 changed files with 3 additions and 1 deletions
  1. +3
    -1
      run_tests.sh

+ 3
- 1
run_tests.sh View File

@@ -17,6 +17,8 @@ export PATH=$PATH:/usr/local/sbin:/usr/sbin

SCENARIO=${SCENARIO:-scenario001}

BRANCH="stable/stein"

# We could want to override the default repositories or install behavior
INSTALL_FROM_SOURCE=${INSTALL_FROM_SOURCE:-true}
MANAGE_REPOS=${MANAGE_REPOS:-true}
@@ -269,7 +271,7 @@ fi

# Setup packstack
if [ "${INSTALL_FROM_SOURCE}" = true ]; then
$SUDO $PIP install --prefix=/usr .
$SUDO $PIP install --ignore-installed -c https://opendev.org/openstack/requirements/raw/branch/$BRANCH/upper-constraints.txt --prefix=/usr .
# In Fedora when running with sudo gems are installed at /usr/local/bin/ even when GEM_HOME/GEM_BIN_DIR are set
if [ "${PKG_MGR}" = "dnf" ]; then
export GEM_BIN_DIR=/usr/local/bin/

Loading…
Cancel
Save