Browse Source

Use upper-constraints file when running tests

Currently, u-c is not uses so we are not using the versions specified in
requirements project.

Change-Id: Id0fd9e98103ff804a43f2d4485f72ac48df261c8
(cherry picked from commit e68d358532)
changes/32/675932/1
Alfredo Moralejo 1 month ago
parent
commit
fa225946f4
1 changed files with 4 additions and 2 deletions
  1. 4
    2
      tox.ini

+ 4
- 2
tox.ini View File

@@ -9,9 +9,11 @@ setenv = VIRTUAL_ENV={envdir}
9 9
          LANG=en_US.UTF-8
10 10
          LANGUAGE=en_US:en
11 11
          LC_ALL=C
12
+deps =
13
+  -c{env:UPPER_CONSTRAINTS_FILE:https://releases.openstack.org/constraints/upper/rocky}
14
+  -r{toxinidir}/test-requirements.txt
15
+  -r{toxinidir}/requirements.txt
12 16
 
13
-deps = -r{toxinidir}/requirements.txt
14
-       -r{toxinidir}/test-requirements.txt
15 17
 commands = /usr/bin/find . -type f -name "*.pyc" -delete
16 18
            stestr run {posargs}
17 19
 

Loading…
Cancel
Save