Browse Source

Drop Python2.7 support

Because Python2.7 is last release of Python2.x series and
Python2.7 support stopped in 2020, we need to drop Python2.7
related things. This commit cleanups Python2.7 related contents.

Change-Id: I92eed041d993af924d93373977aef33cda0f7cf8
changes/24/823924/1
vanou 4 months ago
parent
commit
8bf25f738d
  1. 1
      py27-constraints.txt
  2. 1
      setup.cfg
  3. 8
      tox.ini

1
py27-constraints.txt

@ -1 +0,0 @@
stestr==2.6.0 # Apache-2.0

1
setup.cfg

@ -15,7 +15,6 @@ classifier =
License :: OSI Approved :: Apache Software License
Operating System :: POSIX :: Linux
Programming Language :: Python
Programming Language :: Python :: 2.7
Programming Language :: Python :: 3
[files]

8
tox.ini

@ -1,6 +1,6 @@
[tox]
minversion = 3.9.0
envlist = py3,py27,pep8
envlist = py3,pep8
skipsdist = True
ignore_basepython_conflict=true
@ -27,12 +27,6 @@ commands =
basepython = python3
commands = {posargs}
[testenv:py27]
deps =
-c{toxinidir}/py27-constraints.txt
-r{toxinidir}/requirements.txt
-r{toxinidir}/test-requirements.txt
[testenv:cover]
basepython = python3
setenv =

Loading…
Cancel
Save