Browse Source

Remove test-requirements-py*.txt files

We can control python version sensitive dependencies
in the single test-requirements.txt file so we can
drop the version-specific files. This should also make
the openstack-tox-py35 job start passing.

Change-Id: Ic3fa2c4417092e387ac5d177be75a22050a6f857
changes/71/659371/3
Matt Riedemann 2 years ago
parent
commit
1cc62d6ea2
  1. 1
      test-requirements-py2.txt
  2. 1
      test-requirements-py3.txt
  3. 4
      test-requirements.txt
  4. 6
      tox.ini

1
test-requirements-py2.txt

@ -1 +0,0 @@
ibm_db_sa>=0.3.0

1
test-requirements-py3.txt

@ -1 +0,0 @@
ibm-db-sa-py3

4
test-requirements.txt

@ -19,6 +19,10 @@ testrepository>=0.0.17
testtools>=0.9.34,<0.9.36
tempest-lib>=0.1.0
# db2 support
ibm_db_sa>=0.3.0;python_version<'3.0'
ibm-db-sa-py3;python_version>='3.0'
scripttest
# NOTE(rpodolyaka): This version identifier is currently necessary as
# pytz otherwise does not install on pip 1.4 or higher

6
tox.ini

@ -16,35 +16,29 @@ commands = bash tools/pretty_tox.sh '{posargs}'
[testenv:py27]
deps = sqlalchemy>=0.9
-r{toxinidir}/test-requirements.txt
-r{toxinidir}/test-requirements-py2.txt
[testenv:py27sa07]
basepython = python2.7
deps = sqlalchemy>=0.7,<=0.7.99
-r{toxinidir}/test-requirements.txt
-r{toxinidir}/test-requirements-py2.txt
[testenv:py27sa08]
basepython = python2.7
deps = sqlalchemy>=0.8,<=0.8.99
-r{toxinidir}/test-requirements.txt
-r{toxinidir}/test-requirements-py2.txt
[testenv:py27sa09]
basepython = python2.7
deps = sqlalchemy>=0.9,<=0.9.99
-r{toxinidir}/test-requirements.txt
-r{toxinidir}/test-requirements-py2.txt
[testenv:py33]
deps = sqlalchemy>=0.9
-r{toxinidir}/test-requirements.txt
-r{toxinidir}/test-requirements-py3.txt
[testenv:py34]
deps = sqlalchemy>=0.9
-r{toxinidir}/test-requirements.txt
-r{toxinidir}/test-requirements-py3.txt
[testenv:pep8]
commands = flake8

Loading…
Cancel
Save