Browse Source

Claim support for python 3.6

This adds the voting and gating openstack-tox-py36 job
and adds python 3.6 to the classifiers list.

Change-Id: Ida2349de534399103e5d6f294a7e771910188ee4
changes/88/659388/2
Matt Riedemann 2 years ago
parent
commit
67d2bb2616
  1. 1
      .zuul.yaml
  2. 1
      setup.cfg
  3. 6
      tox.ini

1
.zuul.yaml

@ -3,6 +3,7 @@
- docs-on-readthedocs
- openstack-python-jobs
- openstack-python35-jobs
- openstack-python36-jobs
vars:
rtd_webhook_id: '61274'
check:

1
setup.cfg

@ -19,6 +19,7 @@ classifier =
Programming Language :: Python :: 3.3
Programming Language :: Python :: 3.4
Programming Language :: Python :: 3.5
Programming Language :: Python :: 3.6
[files]
packages =

6
tox.ini

@ -1,7 +1,7 @@
[tox]
minversion = 1.6
skipsdist = True
envlist = py27,py27sa07,py27sa08,py27sa09,py33,py34,py35,pep8
envlist = py27,py27sa07,py27sa08,py27sa09,py33,py34,py35,py36,pep8
[testenv]
usedevelop = True
@ -44,6 +44,10 @@ deps = sqlalchemy>=0.9
deps = sqlalchemy>=0.9
-r{toxinidir}/test-requirements.txt
[testenv:py36]
deps = sqlalchemy>=0.9
-r{toxinidir}/test-requirements.txt
[testenv:pep8]
commands = flake8

Loading…
Cancel
Save