Sync requirements with OpenStack global requirements

Change-Id: Ic9046ea38059b6aa55bb683b07b28e3ff25dae6d
changes/79/451379/1
Ilya Shakhat 6 years ago
parent ac03a19b41
commit 33d8ec8e4f

@ -2,21 +2,21 @@
# of appearance. Changing the order has an impact on the overall integration
# process, which may cause wedges in the gate later.
pbr<2.0,>=1.3
Babel>=1.3
Flask<1.0,>=0.10
iso8601>=0.1.9
oslo.config>=1.11.0 # Apache-2.0
oslo.i18n>=1.5.0 # Apache-2.0
oslo.log>=1.8.0 # Apache-2.0
oslo.serialization>=1.4.0 # Apache-2.0
oslo.utils>=1.9.0 # Apache-2.0
paramiko>=1.13.0
psutil<2.0.0,>=1.1.1
pbr>=2.0.0 # Apache-2.0
Babel>=2.3.4 # BSD
Flask!=0.11,<1.0,>=0.10 # BSD
iso8601>=0.1.11 # MIT
oslo.config>=3.22.0 # Apache-2.0
oslo.i18n>=2.1.0 # Apache-2.0
oslo.log>=3.22.0 # Apache-2.0
oslo.serialization>=1.10.0 # Apache-2.0
oslo.utils>=3.20.0 # Apache-2.0
paramiko>=2.0 # LGPLv2.1+
psutil>=3.2.2 # BSD
PyGithub
python-memcached>=1.56
PyYAML>=3.1.0
requests>=2.5.2
python-memcached>=1.56 # PSF
PyYAML>=3.10.0 # MIT
requests!=2.12.2,!=2.13.0,>=2.10.0 # Apache-2.0
requests-file
sh
six>=1.9.0
six>=1.9.0 # MIT

@ -25,5 +25,5 @@ except ImportError:
pass
setuptools.setup(
setup_requires=['pbr>=1.3'],
setup_requires=['pbr>=2.0.0'],
pbr=True)

@ -41,13 +41,11 @@ LOG = logging.getLogger(__name__)
def get_pids():
# needs to be compatible with psutil >= 1.1.1 since it's a global req.
PSUTIL2 = psutil.version_info >= (2, 0)
result = set([])
for pid in psutil.get_pid_list():
for pid in psutil.pids():
try:
p = psutil.Process(pid)
name = p.name() if PSUTIL2 else p.name
name = p.name()
if name == 'uwsgi':
LOG.debug('Found uwsgi process, pid: %s', pid)
result.add(pid)

@ -3,13 +3,13 @@
# process, which may cause wedges in the gate later.
# Hacking already pins down pep8, pyflakes and flake8
hacking>=0.12.0,!=0.13.0,<0.14 # Apache-2.0
coverage>=3.6
fixtures>=1.3.1
jsonschema!=2.5.0,<3.0.0,>=2.0.0
mock>=1.2
python-subunit>=0.0.18
sphinx!=1.2.0,!=1.3b1,<1.3,>=1.1.2
sphinxcontrib-httpdomain
testrepository>=0.0.18
testtools>=1.4.0
hacking!=0.13.0,<0.14,>=0.12.0 # Apache-2.0
coverage>=4.0 # Apache-2.0
fixtures>=3.0.0 # Apache-2.0/BSD
jsonschema!=2.5.0,<3.0.0,>=2.0.0 # MIT
mock>=2.0 # BSD
python-subunit>=0.0.18 # Apache-2.0/BSD
sphinx>=1.5.1 # BSD
sphinxcontrib-httpdomain # BSD
testrepository>=0.0.18 # Apache-2.0/BSD
testtools>=1.4.0 # MIT

Loading…
Cancel
Save