Browse Source

Remove versions for required packages

Requirement versions were set in the first place to limit the
buginess. However, after some time it appears that it made more
harm than good, as discussed in:
https://review.openstack.org/#/c/388003/

In this commit we remove the versions for all the requirements.

In the future, if a specific dependency version if causing some issue
we should reintroduce the version for this dependency to block the
unstable version.

Sem-Ver: bugfix
Change-Id: Ia42509bf2bf9012cc03c8bb25b84f465425e2aad
changes/75/391075/1
Vincent Llorens 5 years ago
parent
commit
e1ed6abec2
  1. 10
      packaging/rpm/python-synergy.spec
  2. 12
      requirements.txt
  3. 2
      setup.py

10
packaging/rpm/python-synergy.spec

@ -17,11 +17,11 @@ Requires(pre): shadow-utils
Requires(post): systemd
Requires(preun): systemd
Requires(postun): systemd
Requires: python2-eventlet >= 0.17
Requires: python2-oslo-config >= 2.4
Requires: python-pbr >= 1.8
Requires: python-dateutil >= 2.4
Requires: python-requests >= 2.10.0
Requires: python2-eventlet
Requires: python2-oslo-config
Requires: python-pbr
Requires: python-dateutil
Requires: python-requests
%description

12
requirements.txt

@ -2,12 +2,12 @@
# of appearance. Changing the order has an impact on the overall integration
# process, which may cause wedges in the gate later.
pbr>=1.8,<1.9
pbr
eventlet>=0.17,<0.18
oslo.config>=2.4,<2.5
python-dateutil>=2.2,<2.5
requests>=2.7.0,<2.11.0
eventlet
oslo.config
python-dateutil
requests
# Packages not available as system packages (rpm or deb)
tabulate>=0.7.2,<0.8
tabulate

2
setup.py

@ -23,5 +23,5 @@ except ImportError:
pass
setuptools.setup(
setup_requires=['pbr>=1.8', 'setuptools'],
setup_requires=['pbr', 'setuptools'],
pbr=True)
Loading…
Cancel
Save