Browse Source

[Fix gate]Update test requirement

Since pbr already landed and the old version of hacking seems not
work very well with pbr>=2, we should update it to match global
requirement.
Partial-Bug: #1668848

NOTE(yamamoto): I rerun "update-requirements -H" manually

Change-Id: I347c7c25a2e4f1942b2a94689a7909a61279abf5
changes/96/440496/2
ricolin 4 years ago
committed by YAMAMOTO Takashi
parent
commit
aa160147e2
  1. 2
      requirements.txt
  2. 2
      setup.py
  3. 2
      test-requirements.txt

2
requirements.txt

@ -2,5 +2,5 @@
# of appearance. Changing the order has an impact on the overall integration
# process, which may cause wedges in the gate later.
pbr>=1.8 # Apache-2.0
pbr>=2.0.0 # Apache-2.0
Babel>=2.3.4 # BSD

2
setup.py

@ -25,5 +25,5 @@ except ImportError:
pass
setuptools.setup(
setup_requires=['pbr>=1.8'],
setup_requires=['pbr>=2.0.0'],
pbr=True)

2
test-requirements.txt

@ -2,7 +2,7 @@
# of appearance. Changing the order has an impact on the overall integration
# process, which may cause wedges in the gate later.
hacking<0.11,>=0.10.0
hacking!=0.13.0,<0.14,>=0.12.0 # Apache-2.0
coverage>=4.0 # Apache-2.0
python-subunit>=0.0.18 # Apache-2.0/BSD

Loading…
Cancel
Save