Avoid tools/tox_install.sh

Remove tools/tox_install.sh and adjust tox.ini for using it.
There's no need for this anymore.

Change-Id: I2d26dc7f6934f6f08540acb1e866e4d012c004a1
changes/46/553046/1
Andreas Jaeger 5 years ago
parent cce8806f7f
commit 5efa58c4e3

@ -4,14 +4,13 @@ minversion = 2.0
skipsdist = True
[testenv]
install_command = {toxinidir}/tools/tox_install.sh {env:UPPER_CONSTRAINTS_FILE:https://git.openstack.org/cgit/openstack/requirements/plain/upper-constraints.txt} {opts} {packages}
install_command = pip install {opts} {packages}
setenv = VIRTUAL_ENV={envdir}
BRANCH_NAME=master
CLIENT_NAME=vmware-nsxlib
PYTHONWARNINGS=default::DeprecationWarning
passenv = TRACE_FAILONLY GENERATE_HASHES http_proxy HTTP_PROXY https_proxy HTTPS_PROXY no_proxy NO_PROXY
usedevelop = True
deps = -r{toxinidir}/requirements.txt
deps = -c{env:UPPER_CONSTRAINTS_FILE:https://git.openstack.org/cgit/openstack/requirements/plain/upper-constraints.txt}
-r{toxinidir}/requirements.txt
-r{toxinidir}/test-requirements.txt
whitelist_externals = sh
commands =
@ -66,7 +65,8 @@ whitelist_externals =
bash
[testenv:bandit]
deps = -r{toxinidir}/test-requirements.txt
deps = -c{env:UPPER_CONSTRAINTS_FILE:https://git.openstack.org/cgit/openstack/requirements/plain/upper-constraints.txt}
-r{toxinidir}/test-requirements.txt
commands = bandit -r vmware_nsxlib -n 5 -ll
[testenv:cover]

Loading…
Cancel
Save