Browse Source

Bump pbr requirements to >=1.3

This is to fix a downstream issue between nodepool and
diskimage-builder pip dependencies. Since nodepool depends on
diskimage-builder, it would be nice to have common depends.

We also bump hacking to deal with pbr version issues.

Change-Id: I0efa395bc66c9e50bfe4a13e971232ad9184ad48
Signed-off-by: Paul Belanger <pabelanger@redhat.com>
changes/80/223280/1
Paul Belanger 6 years ago
parent
commit
286065ebbc
  1. 2
      requirements.txt
  2. 2
      setup.py
  3. 2
      test-requirements.txt

2
requirements.txt

@ -1,4 +1,4 @@
pbr>=0.6,!=0.7,<1.0
pbr>=1.3
gear
PyYAML

2
setup.py

@ -17,5 +17,5 @@
import setuptools
setuptools.setup(
setup_requires=['pbr>=0.6,!=0.7,<1.0'],
setup_requires=['pbr>=1.3'],
pbr=True)

2
test-requirements.txt

@ -1,5 +1,5 @@
# Nodepool uses hacking for its dependencies
hacking>=0.8,<0.9
hacking>=0.10.2,<0.11
coverage
sphinx>=1.1.2,!=1.2.0,!=1.3b1,<1.3
sphinxcontrib-programoutput

Loading…
Cancel
Save