Browse Source

Update test-requirements ansible version

Zuul depends on ansible>=2.5.1,<2.6

Change-Id: I363144a95f9f33a83e7d211183039185f23e8c24
changes/49/586949/1
Tristan Cacqueray 1 year ago
parent
commit
7deaf1142f
2 changed files with 3 additions and 3 deletions
  1. 2
    2
      test-requirements.txt
  2. 1
    1
      tox.ini

+ 2
- 2
test-requirements.txt View File

@@ -3,9 +3,9 @@
3 3
 # process, which may cause wedges in the gate later.
4 4
 flake8
5 5
 
6
-# We need to pin Ansible to <2.4 until Zuul supports it, otherwise ansible-lint
6
+# We need to pin Ansible to <2.6 until Zuul supports it, otherwise ansible-lint
7 7
 # picks the latest version which is not known to work yet.
8
-ansible<2.4
8
+ansible>=2.5.1,<2.6
9 9
 ansible-lint
10 10
 bashate>=0.2
11 11
 zuul-sphinx>=0.1.1

+ 1
- 1
tox.ini View File

@@ -36,7 +36,7 @@ passenv =
36 36
 deps =
37 37
   # Zuul is required to supply the zuul ansible modules for ansible-lint
38 38
   -egit+https://git.openstack.org/openstack-infra/zuul#egg=zuul
39
-  ansible<2.4.0
39
+  ansible>=2.5.1,<2.6
40 40
   ansible-lint
41 41
   hacking>=0.10,<0.11
42 42
   bashate>=0.2

Loading…
Cancel
Save