Browse Source

Limit ensure-python to Debian/Ubuntu use

While ensure-python has the potential to support more distros,
it currently is limited to Debian based installs. This patch
ensures that, for now, it can only be used for Debian or Ubuntu.

Change-Id: Id02251f211d700d1fdd1fe43d7310b5779c1662d
changes/48/610948/1
Corey Bryant 7 months ago
parent
commit
3d934ebfda
1 changed files with 3 additions and 1 deletions
  1. 3
    1
      roles/ensure-python/tasks/main.yaml

+ 3
- 1
roles/ensure-python/tasks/main.yaml View File

@@ -1,5 +1,7 @@
1 1
 - name: Install specified version of python interpreter and development files
2
-  when: python_version is defined
2
+  when:
3
+    - python_version is defined
4
+    - ansible_distribution == 'Debian' or ansible_distribution == 'Ubuntu'
3 5
   package:
4 6
     name: python{{ python_version }}-dev
5 7
     state: present

Loading…
Cancel
Save