Browse Source

Block installation of requests-toolbelt 0.9.0

This release of requests-toolbelt expects pyOpenSSL to be installed for
urllib3, but does not have it in its default requirements. This is being
tracked in [0], so should be fixed post 0.9.0. For now, block the use of
the 0.9.0 version.

[0] https://github.com/requests/toolbelt/compare/0.8.0...0.9.0

Change-Id: I06445adaaeecf244f6482b6db26db58a09426489
Signed-off-by: Sean McGinnis <sean.mcginnis@gmail.com>
changes/29/633829/2
Sean McGinnis 5 months ago
parent
commit
ee5d385343
No account linked to committer's email address
1 changed files with 1 additions and 1 deletions
  1. 1
    1
      roles/ensure-twine/tasks/main.yaml

+ 1
- 1
roles/ensure-twine/tasks/main.yaml View File

@@ -11,7 +11,7 @@
11 11
 - name: Ensure twine is installed
12 12
   block:
13 13
     - name: Ensure twine is installed
14
-      command: "{{ twine_python }} -m pip install twine!=1.12.0 readme_renderer[md]!=23.0 --user"
14
+      command: "{{ twine_python }} -m pip install twine!=1.12.0 readme_renderer[md]!=23.0 requests-toolbelt!=0.9.0 --user"
15 15
 
16 16
     - name: Set pypi_twine_executable
17 17
       set_fact:

Loading…
Cancel
Save