Remove use of hacking lib

Current hacking library pins on a version of flake8 that is too
old to recognize some py3.5'isms.

Adds ignores for:
  E305 expected 2 blank lines after class or function definition
  E402 module level import not at top of file
  F405 'AnsibleModule' may be undefined, or defined from star imports
  W503 line break before binary operator

Change-Id: I30ae2b6745c8696c58ef1d57790b4268c22cd356
changes/67/466067/2
David Shrewsbury 6 years ago
parent e35885cbde
commit 00457feefd

@ -1,4 +1,6 @@
hacking>=0.12.0,!=0.13.0,<0.14 # Apache-2.0
pep8
pyflakes
flake8
coverage>=3.6
sphinx>=1.5.1,<1.6

@ -51,6 +51,6 @@ commands = python setup.py test --slowest --testr-args='--concurrency=1 {posargs
[flake8]
# These are ignored intentionally in openstack-infra projects;
# please don't submit patches that solely correct them or enable them.
ignore = E125,E129,H
ignore = E305,E125,E129,E402,H,F405,W503
show-source = True
exclude = .venv,.tox,dist,doc,build,*.egg

Loading…
Cancel
Save