Browse Source

Pin elasticsearch to <8.0.0

The latest release 8.0.0 of elasticsearch breaks Zuul when using elasticsearch connection

Trace:
...
File "/usr/local/lib/python3.9/dist-packages/zuul/driver/elasticsearch/con>
self.es = Elasticsearch(
TypeError: __init__() got an unexpected keyword argument 'use_ssl'

Change-Id: Idd4cf9d67f60374fa1e8b9a816845829de31e9f1
changes/33/829033/3
Andy Ladjadj 3 months ago
parent
commit
25a96ed82f
  1. 2
      requirements.txt

2
requirements.txt

@ -34,6 +34,6 @@ routes
jsonpath-rw
urllib3!=1.25.4,!=1.25.5 # https://github.com/urllib3/urllib3/pull/1684
cheroot!=8.1.*,!=8.2.*,!=8.3.0 # https://github.com/cherrypy/cheroot/issues/263
elasticsearch
elasticsearch<8.0.0
PyMySQL
psycopg2-binary

Loading…
Cancel
Save