Browse Source

Add line to setup.cfg limiting to python >=3.5

This adds "Requires-Python: >=3.5" to the PKG-INFO file, which will then
in turn be processed by pypi and pip and prevent users on python2 from
being able to pip install zuul.

Change-Id: Ia2fe96bd151faf4f0c15be79872d4ddf9505b771
changes/89/610089/2
Monty Taylor 3 years ago
parent
commit
522ac60a48
No known key found for this signature in database GPG Key ID: 7BAE94BC7141A594
1 changed files with 1 additions and 0 deletions
  1. +1
    -0
      setup.cfg

+ 1
- 0
setup.cfg View File

@ -6,6 +6,7 @@ description-file =
author = Zuul Team
author-email = zuul-discuss@lists.zuul-ci.org
home-page = https://zuul-ci.org/
python-requires = >=3.5
classifier =
Intended Audience :: Information Technology
Intended Audience :: System Administrators


Loading…
Cancel
Save