Browse Source

Add netaddr requirements for running ipv4|ipv6 filters

Running the ipv4 and ipv6 filters [1] requires the netaddr python
library to be installed on the Ansible *control node*, which ends up
being the executor.
These filters are very useful to determine if an IP is ipv4 or ipv6.

[1]: http://docs.ansible.com/ansible/latest/playbooks_filters_ipaddr.html

Change-Id: I800c7512fc60f9a302fb77cb061610430fcf8e49
changes/22/504522/1
David Moreau-Simard 5 years ago
parent
commit
76954f6610
No known key found for this signature in database
GPG Key ID: FF8D2155E605D693
  1. 1
      requirements.txt

1
requirements.txt

@ -17,6 +17,7 @@ apscheduler>=3.0
PrettyTable>=0.6,<0.8
babel>=1.0
ansible>=2.3.0.0,<2.4
netaddr
kazoo
sqlalchemy
alembic

Loading…
Cancel
Save