Browse Source

Cleanup executor specific requirements

Ara and openstacksdk are installed into the ansible virtualenvs now so
there is no need to pull them as executor specific dependencies.

Change-Id: I3aeac278b8e1f4bb796e0f3a3f475b3c97208a85
tags/3.9.0
Tobias Henkel 5 months ago
parent
commit
8e3d60567b
No account linked to committer's email address
2 changed files with 0 additions and 6 deletions
  1. 0
    3
      Dockerfile
  2. 0
    3
      setup.cfg

+ 0
- 3
Dockerfile View File

@@ -44,10 +44,7 @@ VOLUME /var/lib/zuul
44 44
 CMD ["/usr/local/bin/zuul"]
45 45
 
46 46
 FROM zuul as zuul-executor
47
-COPY --from=builder /output/ /output
48 47
 COPY --from=builder /usr/local/lib/zuul/ /usr/local/lib/zuul
49
-RUN pip install --cache-dir=/output/wheels -r /output/zuul_executor/requirements.txt \
50
-  && rm -rf /output
51 48
 
52 49
 CMD ["/usr/local/bin/zuul-executor"]
53 50
 

+ 0
- 3
setup.cfg View File

@@ -54,6 +54,3 @@ migrate=
54 54
 zuul_base =
55 55
     PyMySQL
56 56
     psycopg2-binary
57
-zuul_executor =
58
-    ara
59
-    openstacksdk

Loading…
Cancel
Save