Browse Source

Update nodejs runtime to version 16

We had been using version 14 which is the previous LTS. Now there are
problems running:

  npx browserslist@latest --update-db

running out of memory. Update to the current nodejs LTS version to
ensure we are running an up to date runtime that hopefully performs more
consistently with the browserslist command.

Change-Id: Ib20c1090ea0f30b7dac2780b6ed963dd6e4b6f77
changes/91/833691/1
Clark Boylan 2 months ago
parent
commit
bb52902303
  1. 2
      .zuul.yaml
  2. 2
      Dockerfile
  3. 2
      tools/install-js-tools.sh
  4. 2
      tools/pip.sh

2
.zuul.yaml

@ -277,7 +277,7 @@
- project:
vars:
node_version: 14
node_version: 16
release_python: python3
check:
jobs:

2
Dockerfile

@ -13,7 +13,7 @@
# See the License for the specific language governing permissions and
# limitations under the License.
FROM docker.io/library/node:14-bullseye as js-builder
FROM docker.io/library/node:16-bullseye as js-builder
COPY web /tmp/src
# Explicitly run the Javascript build

2
tools/install-js-tools.sh

@ -25,7 +25,7 @@ if type apt-get; then
$SUDO apt-get install -y apt-transport-https curl gnupg2
# Install recent NodeJS repo
curl -sS https://deb.nodesource.com/gpgkey/nodesource.gpg.key | $SUDO apt-key add -
echo "deb https://deb.nodesource.com/node_10.x bionic main" | $SUDO tee /etc/apt/sources.list.d/nodesource.list
echo "deb https://deb.nodesource.com/node_16.x focal main" | $SUDO tee /etc/apt/sources.list.d/nodesource.list
# Install yarn repo
curl -sS https://dl.yarnpkg.com/debian/pubkey.gpg | $SUDO apt-key add -
echo "deb https://dl.yarnpkg.com/debian/ stable main" | $SUDO tee /etc/apt/sources.list.d/yarn.list

2
tools/pip.sh

@ -24,7 +24,7 @@ then
# Initialize nodeenv and tell it to re-use the currently active virtualenv
attempts=0
set +e
until nodeenv --python-virtualenv -n 14.3.0 ; do
until nodeenv --python-virtualenv -n 16.14.0 ; do
((attempts++))
if [[ $attempts > 2 ]]
then

Loading…
Cancel
Save