Browse Source

Remove unused puppi dependency

We assert a dependency on this puppi puppet module but then never use
it. Looking at the git log we used it at one time to download tarballs
but then stopped as it wasn't reliable enough.

Clean this up to make puppet 4 happier about this module not having
puppi available in production.

Change-Id: Ifed308229b92035e8b62d8b3677ca698639c6804
master
Clark Boylan 2 months ago
parent
commit
98c85cb0a7
3 changed files with 0 additions and 8 deletions
  1. 0
    1
      Modulefile
  2. 0
    4
      metadata.json
  3. 0
    3
      vagrant.sh

+ 0
- 1
Modulefile View File

@@ -12,6 +12,5 @@ dependency 'puppetlabs/stdlib', '= 3.2.0'
12 12
 dependency 'puppetlabs/mysql', '= 0.6.1'
13 13
 dependency 'puppetlabs/apache', '= 0.0.4'
14 14
 dependency 'puppetlabs/rabbitmq', '= 5.0.0'
15
-dependency 'example42/puppi', '= 2.1.9'
16 15
 dependency 'openstackinfra/vcsrepo', '= 0.0.8'
17 16
 dependency 'stankevich/python', '= 1.6.6'

+ 0
- 4
metadata.json View File

@@ -24,10 +24,6 @@
24 24
       "name": "puppetlabs/rabbitmq",
25 25
       "version_requirement": ">= 4.0.0"
26 26
     },
27
-    {
28
-      "name": "example42/puppi",
29
-      "version_requirement": ">= 2.1.9"
30
-    },
31 27
     {
32 28
       "name": "openstackinfra/vcsrepo",
33 29
       "version_requirement": ">= 0.0.8"

+ 0
- 3
vagrant.sh View File

@@ -21,9 +21,6 @@ fi
21 21
 if [ ! -d /etc/puppet/modules/rabbitmq ]; then
22 22
   puppet module install puppetlabs-rabbitmq --version 5.0.0
23 23
 fi
24
-if [ ! -d /etc/puppet/modules/puppi ]; then
25
-  puppet module install example42-puppi --version 2.1.9
26
-fi
27 24
 if [ ! -d /etc/puppet/modules/vcsrepo ]; then
28 25
   puppet module install openstackinfra-vcsrepo --version 0.0.8
29 26
 fi

Loading…
Cancel
Save