Browse Source

Cap pytest to <6.0.0 to fix pytest-html

We get:

  INTERNALERROR> AttributeError: 'tuple' object has no attribute 'rsplit'

When running pytest-html and this appears related to the recent pytest
6.0.0 release. Cap pytest to <6.0.0 to fix this.

Change-Id: I1379267598099f3ab53c217f15c57f825b8889fa
changes/43/743843/1
Clark Boylan 1 month ago
parent
commit
9946a85183
1 changed files with 3 additions and 1 deletions
  1. +3
    -1
      test-requirements.txt

+ 3
- 1
test-requirements.txt View File

@@ -9,10 +9,12 @@ openstacksdk
zuul-sphinx>=0.2.3
testtools
mock
# pytest 6.0.0 breaks pytest-html
pytest<6.0.0
pytest-html # MPL-2.0
# testinfra 1.17.0 has a broken wheel that won't install under python3
# testinfra 3.0.0 switched the ansible backend, but broke ipv6 handling
testinfra!=1.17.0,!=3.0.0
pytest-html # MPL-2.0
# testinfra's ansible backend actually requires paramiko, but it's not
# specified. After
# https://github.com/philpep/testinfra/pull/454


Loading…
Cancel
Save