Browse Source

Release 3.1.0 releasenotes

As we have created a new tag (3.1.0) let's create a new
releasenotes section in order to present the changes done
in the latest release.

A few formatting issues are fixed as well.

Change-Id: I4f428155dfeb84d3d5424dd58dd0d3b8df375848
changes/97/769297/2
Martin Kopec 1 year ago
parent
commit
0cd2cec87a
  1. 20
      releasenotes/notes/Improve-SSL-configuration-16f0f06a6ade3a3d.yaml
  2. 8
      releasenotes/notes/discover-placement-service-bbd6522424e4eee4.yaml
  3. 1
      releasenotes/source/index.rst
  4. 6
      releasenotes/source/v3.1.0.rst

20
releasenotes/notes/Improve-SSL-configuration-16f0f06a6ade3a3d.yaml

@ -2,16 +2,18 @@
features:
- |
discover-tempest-config can now automatically set the following 2 tempest
options:
* CONF.identity.disable_ssl_certificate_validation
* CONF.identity.ca_certificates_file
options
* ``CONF.identity.disable_ssl_certificate_validation``
* ``CONF.identity.ca_certificates_file``
The mentioned options are set based on cloud's request verify arguments
(verify and cert) read (either set as environent variables or passed via
(verify and cert) read (either set as environment variables or passed via
CLI) by openstack package.
fixes:
- |
Passing a value from --insecure argument is fixed. Previously --insecure
didn't have any effect on discover-tempest-config and its behavior which
lead to failing requests due to certificates verify failures. That is fixed
now. Now the --insecure's value will be stored in the internal Credentials
class and safely pased in requests querying the cloud.
Passing a value from ``--insecure`` argument is fixed. Previously
``--insecure`` didn't have any effect on discover-tempest-config and its
behavior which lead to failing requests due to certificates verify failures.
That is fixed now. Now the --insecure's value will be stored in the
internal Credentials class and safely pased in requests querying the cloud.

8
releasenotes/notes/discover-placement-service-bbd6522424e4eee4.yaml

@ -2,7 +2,9 @@
features:
- |
discover-tempest-config can now automatically set the following 2 tempest
options:
* CONF.placement.min_microversion
* CONF.placement.max_microversion
options
* ``CONF.placement.min_microversion``
* ``CONF.placement.max_microversion``
The mentioned options are set based on the placement service response.

1
releasenotes/source/index.rst

@ -6,6 +6,7 @@
:maxdepth: 1
unreleased
v3.1.0
v3.0.0
v2.5.0
v2.4.0

6
releasenotes/source/v3.1.0.rst

@ -0,0 +1,6 @@
====================
v3.1.0 Release Notes
====================
.. release-notes:: 3.1.0 Release Notes
:version: 3.1.0
Loading…
Cancel
Save