Browse Source

Fix hacking min version to 3.0.1

flake8 new release 3.8.0 added new checks and gate pep8
job start failing. hacking 3.0.1 fix the pinning of flake8 to
avoid bringing in a new version with new checks.

Though it is fixed in latest hacking but 2.0 and 3.0 has cap for
flake8 as <4.0.0 which mean flake8 new version 3.9.0 can also
break the pep8 job if new check are added.

To avoid similar gate break in future, we need to bump the hacking min
version.

Also removing the hacking and other related dep from lower-constraints file
as theose are blacklisted requirements and does not need to be present
there.

This paatch also update minimum tox version in tox.ini file.
- http://lists.openstack.org/pipermail/openstack-discuss/2020-May/014828.html

Change-Id: Ia995caec9c4a0217be523c3179bfee85c1b6f7f8
changes/40/728540/3
manchandavishal 1 year ago
parent
commit
987cc594f6
3 changed files with 6 additions and 6 deletions
  1. +0
    -4
      lower-constraints.txt
  2. +1
    -1
      test-requirements.txt
  3. +5
    -1
      tox.ini

+ 0
- 4
lower-constraints.txt View File

@ -15,7 +15,6 @@ debtcollector==1.19.0
decorator==4.2.1
deprecation==2.0
django-appconf==1.0.2
django-babel==0.6.2
django-compressor==2.0
django-pyscss==2.0.2
Django==2.2
@ -25,9 +24,7 @@ dulwich==0.19.0
extras==1.0.0
fasteners==0.14.1
fixtures==3.0.0
flake8==2.5.5
futurist==1.6.0
hacking==0.12.0
horizon==17.1.0
idna==2.6
imagesize==1.0.0
@ -93,7 +90,6 @@ rfc3986==1.1.0
rjsmin==1.0.12
semantic-version==2.6.0
simplejson==3.13.2
six==1.11.0
snowballstemmer==1.2.1
stevedore==1.28.0
termcolor==1.1.0


+ 1
- 1
test-requirements.txt View File

@ -1,7 +1,7 @@
# The order of packages is significant, because pip processes them in the order
# of appearance. Changing the order has an impact on the overall integration
# process, which may cause wedges in the gate later.
hacking>=3.0,<3.1.0 # Apache-2.0
hacking>=3.0.1,<3.1.0 # Apache-2.0
coverage!=4.4,>=4.0 # Apache-2.0
oslo.config>=5.2.0 # Apache-2.0


+ 5
- 1
tox.ini View File

@ -1,7 +1,11 @@
[tox]
minversion = 1.6
minversion = 3.1.1
envlist = py38,pep8
skipsdist = True
# Automatic envs (pyXX) will only use the python version appropriate to that
# env and ignore basepython inherited from [testenv] if we set
# ignore_basepython_conflict.
ignore_basepython_conflict = True
[testenv]
basepython = python3


Loading…
Cancel
Save