Browse Source

Fix hacking min version to 3.0.1

flake8 new release 3.8.0 added new checks and gate pep8
job start failing. hacking 3.0.1 fix the pinning of flake8 to
avoid bringing in a new version with new checks.

Though it is fixed in latest hacking but 2.0 and 3.0 has cap for
flake8 as <4.0.0 which mean flake8 new version 3.9.0 can also
break the pep8 job if new check are added.

To avoid similar gate break in future, we need to bump the hacking min
version.

- http://lists.openstack.org/pipermail/openstack-discuss/2020-May/014828.html

Change-Id: I7c9c0dc296ac374881c03fcaa6c886e38f3d5d14
changes/19/727619/1
Ghanshyam Mann 1 year ago
parent
commit
51d9b2a996
1 changed files with 1 additions and 1 deletions
  1. +1
    -1
      test-requirements.txt

+ 1
- 1
test-requirements.txt View File

@ -2,7 +2,7 @@
# of appearance. Changing the order has an impact on the overall integration
# process, which may cause wedges in the gate later.
hacking>=3.0,<3.1.0;python_version>='3.5' # Apache-2.0
hacking>=3.0.1,<3.1.0;python_version>='3.5' # Apache-2.0
coverage>=4.0 # Apache-2.0
python-subunit>=0.0.18 # Apache-2.0/BSD


Loading…
Cancel
Save