Add Jammy functesting to dib

This adds arm64 ubuntu-minimal Jammy functests and x86 ubuntu image
based Jammy functests. To make this happen we have to install
debootstrap from debian unstable on the functest nodes in order to get
access to a debootstrap that knows what jammy is.

As we ramp up Jammy support in our tools having good testing will be
helpful.

Change-Id: I1d1dc752ce176457d0656cbd50e27a2721ca9856
changes/91/840391/13
Clark Boylan 9 months ago
parent d3ce32016a
commit 7b6247554e

@ -29,6 +29,7 @@
- fedora/build-succeeds
- ubuntu/bionic-build-succeeds
- ubuntu/focal-build-succeeds
- ubuntu/jammy-build-succeeds
# NOTE(ianw) : these jobs are split to keep the build times a bit more
# reasonable.
@ -42,6 +43,7 @@
dib_functests:
- ubuntu-minimal/bionic-arm64-build-succeeds
- ubuntu-minimal/focal-arm64-build-succeeds
- ubuntu-minimal/jammy-arm64-build-succeeds
- debian-minimal/bullseye-arm64-build-succeeds
- job:

@ -27,6 +27,7 @@ uuid-runtime [platform:dpkg]
yum-utils [platform:dpkg !platform:ubuntu-focal !platform:debian-bullseye]
dnf [platform:debian-bullseye]
debootstrap [platform:dpkg]
zstd [platform:dpkg]
procps [platform:dpkg]
# centos/fedora

@ -0,0 +1,4 @@
Verify we can build a ubuntu-minimal image.
Note this test includes the vm element to test the bootloader install,
and specifies to output a .qcow2

@ -0,0 +1,4 @@
Verify we can build a ubuntu image.
Note this test includes the vm element to test the bootloader install,
and specifies to output a .qcow2

@ -5,5 +5,6 @@
- bindep
- dib-setup-gate-mirrors
- ensure-podman
- dib-ensure-debootstrap
- dib-functests

@ -0,0 +1,2 @@
Update debootstap from debian unstable. This ensures debootstrap is new
enough to recognize Jammy.

@ -0,0 +1,12 @@
- name: Install debootstrap/unstable
# This is shell because doing it with native ansible modules went nowhere
become: yes
shell: |
set -ex
echo "APT::Default-Release: 'stable';" > /etc/apt/apt.conf.d/default-release
echo "deb http://deb.debian.org/debian unstable main" > /etc/apt/sources.list.d/unstable-debian.list
apt-get update
apt-get install -y debootstrap/unstable
# Remove the use of unstable as it seems to interfere with other tasks
rm /etc/apt/sources.list.d/unstable-debian.list
apt-get update
Loading…
Cancel
Save