Browse Source

Changed minversion in tox to 3.18.0

The patch bumps min version of tox to 3.18.0 python in order to
replace tox's whitelist_externals by allowlist_externals option:
https://github.com/tox-dev/tox/blob/master/docs/changelog.rst#v3180-2020-07-23
The patch also sets ubuntu-focal nodeset for the docs job as newer
ubuntu (with newer tox available) is required.

Change-Id: I5b32e7f65710199601a6856dba86584390eb92b7
changes/32/790332/5
Anand Bhat 5 months ago
committed by Martin Kopec
parent
commit
3b8a9126db
  1. 15
      .zuul.yaml
  2. 6
      tox.ini

15
.zuul.yaml

@ -1,4 +1,15 @@
- project:
templates:
- nodejs4-jobs
- nodejs10-docs
- nodejs14-jobs
check:
jobs:
- nodejs-run-docs:
vars:
node_version: 14
nodeset: ubuntu-focal
gate:
jobs:
- nodejs-run-docs:
vars:
node_version: 14
nodeset: ubuntu-focal

6
tox.ini

@ -1,5 +1,5 @@
[tox]
minversion = 2.4.0
minversion = 3.18.0
skipsdist = True
ignore_basepython_conflict = True
@ -20,11 +20,11 @@ deps =
commands =
rm -rf doc/build
sphinx-build -W -b html doc/source doc/build/html
whitelist_externals = rm
allowlist_externals = rm
[testenv:pdf-docs]
deps = {[testenv:docs]deps}
whitelist_externals =
allowlist_externals =
make
commands =
sphinx-build -W -b latex doc/source doc/build/pdf

Loading…
Cancel
Save