Browse Source

Merge "Use babel-plugin-transform-runtime instead of babel-polyfill"

Jenkins 2 years ago
parent
commit
a9bac97fab
3 changed files with 4 additions and 3 deletions
  1. 2
    1
      .babelrc
  2. 2
    1
      package.json
  3. 0
    1
      src/index.js

+ 2
- 1
.babelrc View File

@@ -1,3 +1,4 @@
1 1
 {
2
-  "presets": ["es2015"]
2
+  "presets": ["es2015"],
3
+  "plugins": ["transform-runtime"]
3 4
 }

+ 2
- 1
package.json View File

@@ -29,7 +29,7 @@
29 29
   "license": "Apache-2.0",
30 30
   "homepage": "http://www.openstack.org/",
31 31
   "dependencies": {
32
-    "babel-polyfill": "^6.9.1",
32
+    "babel-runtime": "^6.11.6",
33 33
     "isomorphic-fetch": "^2.2.1",
34 34
     "loglevel": "^1.4.1"
35 35
   },
@@ -38,6 +38,7 @@
38 38
     "babel-core": "^6.10.4",
39 39
     "babel-loader": "^6.2.4",
40 40
     "babel-plugin-transform-inline-environment-variables": "^6.8.0",
41
+    "babel-plugin-transform-runtime": "^6.15.0",
41 42
     "babel-preset-es2015": "^6.9.0",
42 43
     "babel-register": "^6.9.0",
43 44
     "eslint": "^3.0.0",

+ 0
- 1
src/index.js View File

@@ -1,4 +1,3 @@
1
-import 'babel-polyfill';
2 1
 import 'isomorphic-fetch';
3 2
 
4 3
 export default class Test {

Loading…
Cancel
Save