Added node-security-project checks

This projects' dependencies will now be checked against the
node-security list of advisories. A build will fail if a CVE is
detected.

Change-Id: I9ec06fe00794f0b178389548ed0c88f6036b6e86
changes/68/332468/3
Michael Krotscheck 7 years ago
parent 0e09469508
commit b7c4155384

@ -5,7 +5,8 @@
"main": "index.js",
"scripts": {
"test": "exit 0",
"lint": "eslint ./"
"lint": "eslint ./",
"prepublish": "nsp check"
},
"repository": {
"type": "git",
@ -19,6 +20,7 @@
"homepage": "http://www.openstack.org/",
"devDependencies": {
"eslint": "^2.4.0",
"eslint-config-openstack": "2.0.0"
"eslint-config-openstack": "2.0.0",
"nsp": "^2.4.0"
}
}

Loading…
Cancel
Save