Ignore Python warnings in kolla-toolbox

Ansible 2.2.0.0 used in Stein kolla-toolbox requires paramiko (no version
constraints), which installs latest cryptography package. It results in
Python deprecation warning about Python 2:

/usr/lib64/python2.7/site-packages/cryptography/__init__.py:39: CryptographyDeprecationWarning: Python 2 is no longer supported by the Python core team. Support for it is now deprecated in cryptography, and will be removed in a future release.

This warning breaks kolla_toolbox module.

Closes-Bug: #1888657

Change-Id: I3e38946d9dabd5df8bf7c6202a8b739304fe4622
changes/42/742642/3
Michal Nasiadka 2 years ago
parent 84d9d78e5f
commit bbaa82619e
  1. 1
      ansible/roles/common/defaults/main.yml
  2. 6
      releasenotes/notes/bug-1888657-44e2f6f3aedc20ba.yaml

@ -26,6 +26,7 @@ common_services:
environment:
ANSIBLE_NOCOLOR: "1"
ANSIBLE_LIBRARY: "/usr/share/ansible"
PYTHONWARNINGS: "ignore::UserWarning"
privileged: True
volumes:
- "{{ node_config_directory }}/kolla-toolbox/:{{ container_config_directory }}/:ro"

@ -0,0 +1,6 @@
---
fixes:
- |
This patch fixes a bug, when kolla_toolbox Ansible module failed due to
Python deprecation warnings caused by paramiko/cryptography.
`LP#1888657 <https://launchpad.net/bugs/1888657>`__
Loading…
Cancel
Save