Browse Source

Fix CI issues

Bump requirements and lower-constraints libs to allow kuryr to work with
the new pip resolver.

Also update the DevStack plugin to query for docker's cgroup driver
correctly, because the old way suddenly stopped working.

Change-Id: I4f176e2eda194b060abc33e7d1541078cb78d97f
changes/75/766075/18
Maysa Macedo 2 months ago
committed by Michał Dulko
parent
commit
ccc220bbbd
4 changed files with 6 additions and 6 deletions
  1. +1
    -1
      devstack/lib/kuryr_kubernetes
  2. +1
    -1
      devstack/plugin.sh
  3. +3
    -3
      lower-constraints.txt
  4. +1
    -1
      requirements.txt

+ 1
- 1
devstack/lib/kuryr_kubernetes View File

@ -885,7 +885,7 @@ function run_openshift_node {
--network-plugin=cni \
--address=0.0.0.0 \
--port=10250 \
--cgroup-driver $(docker info|awk '/Cgroup/ {print $NF}') \
--cgroup-driver $(docker info -f '{{.CgroupDriver}}') \
--fail-swap-on=false \
--allow-privileged=true \
--v=2 \


+ 1
- 1
devstack/plugin.sh View File

@ -751,7 +751,7 @@ function run_k8s_kubelet {
--root-dir=${KURYR_KUBERNETES_DATA_DIR}/kubelet"
if [[ ${CONTAINER_ENGINE} == 'docker' ]]; then
command+=" --cgroup-driver $(docker info|awk '/Cgroup/ {print $NF}')"
command+=" --cgroup-driver $(docker info -f '{{.CgroupDriver}}')"
elif [[ ${CONTAINER_ENGINE} == 'crio' ]]; then
local crio_conf
crio_conf=/etc/crio/crio.conf


+ 3
- 3
lower-constraints.txt View File

@ -43,7 +43,7 @@ kombu==4.1.0
kuryr-lib==0.5.0
linecache2==1.0.0
Mako==1.0.7
MarkupSafe==1.0
MarkupSafe==1.1.0
monotonic==1.4
mox3==0.25.0
msgpack==0.5.6
@ -66,7 +66,7 @@ oslo.log==3.36.0
oslo.messaging==5.36.0
oslo.middleware==3.35.0
oslo.policy==1.34.0
oslo.privsep==1.28.0
oslo.privsep==1.33.3
oslo.reports==1.18.0
oslo.serialization==2.18.0
oslo.service==1.40.2
@ -97,7 +97,7 @@ python-subunit==1.0.0
pytz==2018.3
PyYAML==3.12
repoze.lru==0.7
requests==2.18.0
requests==2.18.4
requestsexceptions==1.4.0
retrying==1.2.3
rfc3986==1.1.0


+ 1
- 1
requirements.txt View File

@ -6,7 +6,7 @@ cotyledon>=1.5.0 # Apache-2.0
Flask!=0.11,>=0.12.3 # BSD
kuryr-lib>=0.5.0 # Apache-2.0
pbr!=2.1.0,>=2.0.0 # Apache-2.0
requests>=2.18.0 # Apache-2.0
requests>=2.18.4 # Apache-2.0
eventlet>=0.22.0 # MIT
netaddr>=0.7.19 # BSD
openstacksdk>=0.36.0 # Apache-2.0


Loading…
Cancel
Save