Browse Source

Fix gate - update lower-constraints

Story: 2008482
Task: 41522

Change-Id: I875b9b2e0ef8bb6751a27e9a917a6d58042570ce
changes/28/767228/42
Feilong Wang 6 months ago
committed by Michal Nasiadka
parent
commit
94737878af
5 changed files with 115 additions and 117 deletions
  1. +62
    -63
      lower-constraints.txt
  2. +38
    -38
      requirements.txt
  3. +1
    -1
      setup.cfg
  4. +11
    -12
      test-requirements.txt
  5. +3
    -3
      tox.ini

+ 62
- 63
lower-constraints.txt View File

@ -1,33 +1,33 @@
alabaster==0.7.10
alembic==0.8.10
amqp==2.2.2
alembic==0.9.6
amqp==2.6.1
appdirs==1.4.3
asn1crypto==0.24.0
automaton==1.14.0
Babel==2.3.4
bandit==1.1.0
bashate==0.5.1
bashate==2.0.0
beautifulsoup4==4.6.0
cachetools==2.0.1
certifi==2018.1.18
cffi==1.11.5
cffi==1.14.0
chardet==3.0.4
cliff==2.8.0
cmd2==0.8.1
contextlib2==0.5.5
coverage==4.0
cryptography==2.1
coverage==5.3
cryptography==2.1.4
debtcollector==1.19.0
decorator==3.4.0
deprecation==2.0
doc8==0.6.0
doc8==0.8.1
docker-pycreds==0.2.2
docker==2.4.2
docker==4.3.0
docutils==0.14
dogpile.cache==0.6.5
dulwich==0.19.0
enum-compat==0.0.2
eventlet==0.18.2
eventlet==0.28.0
extras==1.0.0
fasteners==0.14.1
fixtures==3.0.0
@ -46,16 +46,16 @@ jmespath==0.9.3
jsonpatch==1.16
jsonpointer==2.0
jsonschema==2.6.0
keystoneauth1==3.4.0
keystonemiddleware==4.17.0
kombu==4.1.0
kubernetes==5.0.0
keystoneauth1==3.14.0
keystonemiddleware==9.0.0
kombu==5.0.1
kubernetes==12.0.0
linecache2==1.0.0
logutils==0.3.5
Mako==1.0.7
marathon==0.8.6
MarkupSafe==1.0
mccabe==0.2.1
mccabe==0.6.0
monotonic==1.4
mox3==0.25.0
msgpack==0.5.6
@ -64,35 +64,34 @@ netaddr==0.7.18
netifaces==0.10.6
networkx==1.11
oauthlib==2.0.6
openstacksdk==0.12.0
openstacksdk==0.15.0
os-api-ref==1.4.0
os-client-config==1.29.0
os-service-types==1.2.0
os-testr==1.0.0
osc-lib==1.10.0
oslo.cache==1.29.0
oslo.concurrency==3.26.0
oslo.config==5.2.0
oslo.context==2.19.2
oslo.db==4.27.0
oslo.i18n==3.15.3
oslo.log==3.36.0
oslo.messaging==5.29.0
oslo.middleware==3.31.0
oslo.policy==1.30.0
oslo.reports==1.18.0
oslo.serialization==2.18.0
oslo.service==1.24.0
oslo.upgradecheck==0.1.1
oslo.utils==3.33.0
oslo.versionedobjects==1.31.2
oslotest==3.2.0
osprofiler==1.4.0
packaging==17.1
osc-lib==2.1.0
oslo.cache==2.4.0
oslo.concurrency==4.1.0
oslo.config==8.1.0
oslo.context==3.1.0
oslo.db==8.2.0
oslo.i18n==5.0.0
oslo.log==4.2.0
oslo.messaging==12.2.0
oslo.middleware==4.1.0
oslo.policy==3.2.0
oslo.reports==2.1.0
oslo.serialization==3.2.0
oslo.service==2.2.0
oslo.upgradecheck==1.1.0
oslo.utils==4.2.0
oslo.versionedobjects==2.1.0
oslotest==4.4.1
osprofiler==3.4.0
packaging==20.4
Paste==2.0.3
PasteDeploy==1.5.2
pbr==2.0.0
pecan==1.0.0
pbr==5.5.0
pecan==1.3.3
pika-pool==0.1.3
pika==0.10.0
prettytable==0.7.2
@ -101,63 +100,63 @@ pyasn1-modules==0.2.1
pyasn1==0.4.2
pycadf==1.1.0
pycparser==2.18
Pygments==2.2.0
Pygments==2.7.2
pyinotify==0.9.6
pyOpenSSL==17.5.0
pyparsing==2.2.0
pyperclip==1.6.0
python-barbicanclient==4.5.2
python-barbicanclient==5.0.0
python-dateutil==2.7.0
python-editor==1.0.3
python-glanceclient==2.8.0
python-cinderclient==2.2.0
python-heatclient==1.10.0
python-keystoneclient==3.8.0
python-glanceclient==3.2.0
python-cinderclient==7.1.0
python-heatclient==2.2.0
python-keystoneclient==3.20.0
python-mimeparse==1.6.0
python-neutronclient==6.7.0
python-novaclient==9.1.0
python-octaviaclient==1.6.0
python-subunit==1.0.0
python-swiftclient==3.5.0
pytz==2013.6
PyYAML==3.12
python-neutronclient==7.2.0
python-novaclient==17.2.0
python-octaviaclient==2.1.0
python-subunit==1.4.0
python-swiftclient==3.10.0
pytz==2020.4
PyYAML==3.13
repoze.lru==0.7
requests-oauthlib==0.8.0
requests-toolbelt==0.8.0
requests==2.14.2
requests==2.20.1
requestsexceptions==1.4.0
restructuredtext-lint==1.1.3
rfc3986==1.1.0
rfc3986==1.2.0
Routes==2.4.1
rsa==3.4.2
setuptools==21.0.0
setuptools==30.0.0
simplegeneric==0.8.1
simplejson==3.13.2
six==1.10.0
smmap2==2.0.3
snowballstemmer==1.2.1
sqlalchemy-migrate==0.11.0
SQLAlchemy==1.0.10
SQLAlchemy==1.2.0
sqlparse==0.2.4
statsd==3.2.2
stestr==2.0.0
stevedore==1.20.0
stestr==3.1.0
stevedore==3.3.0
taskflow==2.16.0
Tempita==0.5.2
tenacity==4.9.0
testrepository==0.0.18
stestr==2.0.0
testrepository==0.0.20
stestr==3.1.0
testresources==2.0.1
testscenarios==0.4
testtools==2.2.0
testtools==2.4.0
traceback2==1.4.0
unittest2==1.1.0
urllib3==1.22
urllib3==1.24.2
vine==1.1.4
voluptuous==0.11.1
waitress==1.1.0
warlock==1.3.0
WebOb==1.7.1
warlock==1.3.1
WebOb==1.8.1
websocket-client==0.47.0
WebTest==2.0.29
Werkzeug==0.9


+ 38
- 38
requirements.txt View File

@ -6,52 +6,52 @@
# ascii betical order.
Babel!=2.4.0,>=2.3.4 # BSD
PyYAML>=3.12 # MIT
SQLAlchemy!=1.1.5,!=1.1.6,!=1.1.7,!=1.1.8,>=1.0.10 # MIT
PyYAML>=3.13 # MIT
SQLAlchemy>=1.2.0 # MIT
WSME>=0.8.0 # MIT
WebOb>=1.7.1 # MIT
alembic>=0.8.10 # MIT
WebOb>=1.8.1 # MIT
alembic>=0.9.6 # MIT
cliff!=2.9.0,>=2.8.0 # Apache-2.0
decorator>=3.4.0 # BSD
docker>=2.4.2 # Apache-2.0
eventlet!=0.18.3,!=0.20.1,>=0.18.2 # MIT
docker>=4.3.0 # Apache-2.0
eventlet>=0.28.0 # MIT
iso8601>=0.1.11 # MIT
jsonpatch!=1.20,>=1.16 # BSD
keystoneauth1>=3.4.0 # Apache-2.0
keystonemiddleware>=4.17.0 # Apache-2.0
kubernetes>=5.0.0 # Apache-2.0
keystoneauth1>=3.14.0 # Apache-2.0
keystonemiddleware>=9.0.0 # Apache-2.0
kubernetes>=12.0.0 # Apache-2.0
marathon!=0.9.1,>=0.8.6 # MIT
netaddr>=0.7.18 # BSD
oslo.concurrency>=3.26.0 # Apache-2.0
oslo.config>=5.2.0 # Apache-2.0
oslo.context>=2.19.2 # Apache-2.0
oslo.db>=4.27.0 # Apache-2.0
oslo.i18n>=3.15.3 # Apache-2.0
oslo.log>=3.36.0 # Apache-2.0
oslo.messaging>=5.29.0 # Apache-2.0
oslo.middleware>=3.31.0 # Apache-2.0
oslo.policy>=1.30.0 # Apache-2.0
oslo.serialization!=2.19.1,>=2.18.0 # Apache-2.0
oslo.service!=1.28.1,>=1.24.0 # Apache-2.0
oslo.upgradecheck>=0.1.1 # Apache-2.0
oslo.utils>=3.33.0 # Apache-2.0
oslo.versionedobjects>=1.31.2 # Apache-2.0
oslo.reports>=1.18.0 # Apache-2.0
pbr!=2.1.0,>=2.0.0 # Apache-2.0
pecan!=1.0.2,!=1.0.3,!=1.0.4,!=1.2,>=1.0.0 # BSD
oslo.concurrency>=4.1.0 # Apache-2.0
oslo.config>=8.1.0 # Apache-2.0
oslo.context>=3.1.0 # Apache-2.0
oslo.db>=8.2.0 # Apache-2.0
oslo.i18n>=5.0.0 # Apache-2.0
oslo.log>=4.2.0 # Apache-2.0
oslo.messaging>=12.2.0 # Apache-2.0
oslo.middleware>=4.1.0 # Apache-2.0
oslo.policy>=3.2.0 # Apache-2.0
oslo.reports>=2.1.0 # Apache-2.0
oslo.serialization>=3.2.0 # Apache-2.0
oslo.service>=2.2.0 # Apache-2.0
oslo.upgradecheck>=1.1.0 # Apache-2.0
oslo.utils>=4.2.0 # Apache-2.0
oslo.versionedobjects>=2.1.0 # Apache-2.0
pbr>=5.5.0 # Apache-2.0
pecan>=1.3.3 # BSD
pycadf!=2.0.0,>=1.1.0 # Apache-2.0
python-barbicanclient>=4.5.2 # Apache-2.0
python-cinderclient>=2.2.0 # Apache-2.0
python-glanceclient>=2.8.0 # Apache-2.0
python-heatclient>=1.10.0 # Apache-2.0
python-neutronclient>=6.7.0 # Apache-2.0
python-novaclient>=9.1.0 # Apache-2.0
python-keystoneclient>=3.8.0 # Apache-2.0
python-octaviaclient>=1.6.0 # Apache-2.0
requests>=2.14.2 # Apache-2.0
setuptools!=24.0.0,!=34.0.0,!=34.0.1,!=34.0.2,!=34.0.3,!=34.1.0,!=34.1.1,!=34.2.0,!=34.3.0,!=34.3.1,!=34.3.2,!=36.2.0,>=21.0.0 # PSF/ZPL
python-barbicanclient>=5.0.0 # Apache-2.0
python-cinderclient>=7.1.0 # Apache-2.0
python-glanceclient>=3.2.0 # Apache-2.0
python-heatclient>=2.2.0 # Apache-2.0
python-neutronclient>=7.2.0 # Apache-2.0
python-novaclient>=17.2.0 # Apache-2.0
python-keystoneclient>=3.20.0 # Apache-2.0
python-octaviaclient>=2.1.0 # Apache-2.0
requests>=2.20.1 # Apache-2.0
setuptools!=34.0.0,!=34.0.1,!=34.0.2,!=34.0.3,!=34.1.0,!=34.1.1,!=34.2.0,!=34.3.0,!=34.3.1,!=34.3.2,!=36.2.0,>=30.0.0 # PSF/ZPL
six>=1.10.0 # MIT
stevedore>=1.20.0 # Apache-2.0
stevedore>=3.3.0 # Apache-2.0
taskflow>=2.16.0 # Apache-2.0
cryptography>=2.1 # BSD/Apache-2.0
cryptography>=2.1.4 # BSD/Apache-2.0
Werkzeug>=0.9 # BSD License

+ 1
- 1
setup.cfg View File

@ -82,4 +82,4 @@ magnum.cert_manager.backend =
x509keypair = magnum.common.cert_manager.x509keypair_cert_manager
[extras]
osprofiler =
osprofiler>=1.4.0 # Apache-2.0
osprofiler>=3.4.0 # Apache-2.0

+ 11
- 12
test-requirements.txt View File

@ -6,18 +6,17 @@
# ascii betical order.
bandit!=1.6.0,>=1.1.0 # Apache-2.0
bashate>=0.5.1 # Apache-2.0
coverage!=4.4,>=4.0 # Apache-2.0
doc8>=0.6.0 # Apache-2.0
bashate>=2.0.0 # Apache-2.0
coverage>=5.3 # Apache-2.0
doc8>=0.8.1 # Apache-2.0
fixtures>=3.0.0 # Apache-2.0/BSD
hacking>=3.0.1,<3.1.0 # Apache-2.0
oslotest>=3.2.0 # Apache-2.0
osprofiler>=1.4.0 # Apache-2.0
os-testr>=1.0.0 # Apache-2.0
Pygments>=2.2.0 # BSD license
python-subunit>=1.0.0 # Apache-2.0/BSD
pytz>=2013.6 # MIT
testrepository>=0.0.18 # Apache-2.0/BSD
stestr>=2.0.0 # Apache-2.0
oslotest>=4.4.1 # Apache-2.0
osprofiler>=3.4.0 # Apache-2.0
Pygments>=2.7.2 # BSD license
python-subunit>=1.4.0 # Apache-2.0/BSD
pytz>=2020.4 # MIT
testrepository>=0.0.20 # Apache-2.0/BSD
stestr>=3.1.0 # Apache-2.0
testscenarios>=0.4 # Apache-2.0/BSD
testtools>=2.2.0 # MIT
testtools>=2.4.0 # MIT

+ 3
- 3
tox.ini View File

@ -6,8 +6,6 @@ skipsdist = True
[testenv]
basepython = python3
usedevelop = True
install_command =
pip install -c{env:UPPER_CONSTRAINTS_FILE:https://opendev.org/openstack/requirements/raw/branch/master/upper-constraints.txt} {opts} {packages}
whitelist_externals = bash
find
rm
@ -16,7 +14,8 @@ setenv =
PYTHONWARNINGS=default::DeprecationWarning
OS_STDOUT_CAPTURE=1
OS_STDERR_CAPTURE=1
deps = -r{toxinidir}/requirements.txt
deps = -c{env:UPPER_CONSTRAINTS_FILE:https://releases.openstack.org/constraints/upper/master}
-r{toxinidir}/requirements.txt
-r{toxinidir}/test-requirements.txt
passenv = TEMPEST_* OS_TEST_*
commands =
@ -186,6 +185,7 @@ commands =
sphinx-build -W --keep-going -b html -d api-ref/build/doctrees api-ref/source api-ref/build/html
[testenv:lower-constraints]
deps =
-c{toxinidir}/lower-constraints.txt
-r{toxinidir}/test-requirements.txt


Loading…
Cancel
Save