Browse Source

Drop install_command usage in tox

Use the default value provided by tox:

https://tox.readthedocs.io/en/latest/config.html#conf-install_command

See discussion on the openstack-discuss ML [1]
for the complete context.

To get this fix in, we'll need to raise
a few requirements:

- eventlet because of the ssl issues with python3.6 in
  older packages
  (https://github.com/eventlet/eventlet/issues/371)
- oslo.messaging to fix the error "ACCESS_REFUSED - Login
  was refused using authentication mechanism AMQPLAIN.".
- psycopg2-binary since 2.6.2 is blacklisted
- oslo.service was bumped to 2.1.0, to pick up its support
  for eventlet>=0.22
- oslo.utils was bumped to match the lower constraint from
  oslo.service at 2.1.0

[1] http://lists.openstack.org/pipermail/openstack-discuss/2020-April/014237.html

Change-Id: I6344f44fb955d631a4f0a13fa53ecc19826c7ea6
Signed-off-by: Goutham Pacha Ravi <gouthampravi@gmail.com>
changes/73/722173/6
Goutham Pacha Ravi 1 year ago
parent
commit
0a499674d5
4 changed files with 14 additions and 13 deletions
  1. +5
    -5
      lower-constraints.txt
  2. +4
    -4
      requirements.txt
  3. +1
    -1
      test-requirements.txt
  4. +4
    -3
      tox.ini

+ 5
- 5
lower-constraints.txt View File

@ -23,7 +23,7 @@ docutils==0.14
dogpile.cache==0.6.5
dulwich==0.19.0
enum-compat==0.0.2
eventlet==0.18.2
eventlet==0.22.0
extras==1.0.0
fasteners==0.14.1
fixtures==3.0.0
@ -66,15 +66,15 @@ oslo.context==2.19.2
oslo.db==4.27.0
oslo.i18n==3.15.3
oslo.log==3.36.0
oslo.messaging==5.29.0
oslo.messaging==6.4.0
oslo.middleware==3.31.0
oslo.policy==1.30.0
oslo.reports==1.18.0
oslo.rootwrap==5.8.0
oslo.serialization==2.18.0
oslo.service==1.24.0
oslo.service==2.1.1
oslo.upgradecheck==0.1.0
oslo.utils==3.33.0
oslo.utils==3.40.2
oslotest==3.2.0
packaging==17.1
paramiko==2.0.0
@ -85,7 +85,7 @@ pika==0.10.0
pika-pool==0.1.3
prettytable==0.7.2
psutil==5.4.3
psycopg2-binary==2.6.2
psycopg2-binary==2.8.5
pyasn1==0.4.2
pycadf==2.7.0
pycparser==2.18


+ 4
- 4
requirements.txt View File

@ -7,7 +7,7 @@ pbr!=2.1.0,>=2.0.0 # Apache-2.0
alembic>=0.8.10 # MIT
Babel!=2.4.0,>=2.3.4 # BSD
eventlet!=0.18.3,!=0.20.1,>=0.18.2 # MIT
eventlet>=0.22.0,!=0.23.0,!=0.25.0 # MIT
greenlet>=0.4.10 # MIT
lxml!=3.7.0,>=3.4.1 # BSD
netaddr>=0.7.18 # BSD
@ -16,15 +16,15 @@ oslo.context>=2.19.2 # Apache-2.0
oslo.db>=4.27.0 # Apache-2.0
oslo.i18n>=3.15.3 # Apache-2.0
oslo.log>=3.36.0 # Apache-2.0
oslo.messaging>=5.29.0 # Apache-2.0
oslo.messaging>=6.4.0 # Apache-2.0
oslo.middleware>=3.31.0 # Apache-2.0
oslo.policy>=1.30.0 # Apache-2.0
oslo.reports>=1.18.0 # Apache-2.0
oslo.rootwrap>=5.8.0 # Apache-2.0
oslo.serialization!=2.19.1,>=2.18.0 # Apache-2.0
oslo.service!=1.28.1,>=1.24.0 # Apache-2.0
oslo.service>=2.1.1 # Apache-2.0
oslo.upgradecheck>=0.1.0 # Apache-2.0
oslo.utils>=3.33.0 # Apache-2.0
oslo.utils>=3.40.2 # Apache-2.0
oslo.concurrency>=3.26.0 # Apache-2.0
paramiko>=2.0.0 # LGPLv2.1+
Paste>=2.0.2 # MIT


+ 1
- 1
test-requirements.txt View File

@ -16,7 +16,7 @@ oslotest>=3.2.0 # Apache-2.0
# by oslo_db lib for running MySQL and PostgreSQL DB migration tests.
# See https://docs.openstack.org/oslo.db/latest/contributor/index.html#how-to-run-unit-tests
PyMySQL>=0.7.6 # MIT License
psycopg2-binary>=2.6.2 # LGPL/ZPL
psycopg2-binary>=2.8.5 # LGPL/ZPL
requests-mock>=1.2.0 # Apache-2.0
os-api-ref>=1.4.0 # Apache-2.0


+ 4
- 3
tox.ini View File

@ -7,10 +7,11 @@ envlist = py3,pep8
basepython = python3
setenv = VIRTUAL_ENV={envdir}
usedevelop = True
install_command = pip install -c{env:UPPER_CONSTRAINTS_FILE:https://releases.openstack.org/constraints/upper/master} {opts} {packages}
whitelist_externals = find
deps = -r{toxinidir}/requirements.txt
-r{toxinidir}/test-requirements.txt
deps =
-c{env:UPPER_CONSTRAINTS_FILE:https://releases.openstack.org/constraints/upper/master}
-r{toxinidir}/requirements.txt
-r{toxinidir}/test-requirements.txt
commands =
find . -type f -name "*.py[c|o]" -delete
stestr run {posargs}


Loading…
Cancel
Save