Browse Source

Cleanup Python 2.7 support

OpenStack is dropping the py2.7 support in ussuri cycle.

Make a few cleanups:
- Remove python 2.7 stanza from setup.py
- Add requires on python >= 3.6 to setup.cfg so that pypi and pip
  know about the requirement
- Remove section from setup.cfg: Wheel is not needed for python
  3 only repo
- Update requirements

Change-Id: Ibca03f9ebaeaca595e027be9cb5900c368c8de6d
tags/10.0.0.0rc1
Andreas Jaeger 3 months ago
parent
commit
a4d4159820
4 changed files with 2 additions and 13 deletions
  1. +1
    -1
      doc/requirements.txt
  2. +0
    -1
      requirements.txt
  3. +1
    -3
      setup.cfg
  4. +0
    -8
      setup.py

+ 1
- 1
doc/requirements.txt View File

@@ -4,7 +4,7 @@
openstackdocstheme>=1.31.2 # Apache-2.0
reno>=2.5.0 # Apache-2.0
doc8>=0.6.0 # Apache-2.0
sphinx!=1.6.6,!=1.6.7,!=2.1.0,>=1.6.2;python_version>='3.4' # BSD
sphinx!=1.6.6,!=1.6.7,!=2.1.0,>=1.6.2 # BSD
mock>=2.0.0 # BSD
os-api-ref>=1.4.0 # Apache-2.0
ddt>=1.0.1 # MIT


+ 0
- 1
requirements.txt View File

@@ -9,7 +9,6 @@ alembic>=0.8.10 # MIT
Babel!=2.4.0,>=2.3.4 # BSD
eventlet!=0.18.3,!=0.20.1,>=0.18.2 # MIT
greenlet>=0.4.10 # MIT
ipaddress>=1.0.17;python_version<'3.3' # PSF
lxml!=3.7.0,>=3.4.1 # BSD
netaddr>=0.7.18 # BSD
oslo.config>=5.2.0 # Apache-2.0


+ 1
- 3
setup.cfg View File

@@ -6,6 +6,7 @@ description-file =
author = OpenStack
author-email = openstack-discuss@lists.openstack.org
home-page = https://docs.openstack.org/manila/latest/
python-requires = >=3.6
classifier =
Environment :: OpenStack
Intended Audience :: Information Technology
@@ -104,6 +105,3 @@ input_file = manila/locale/manila.pot
keywords = _ gettext ngettext l_ lazy_gettext
mapping_file = babel.cfg
output_file = manila/locale/manila.pot

[wheel]
universal = 1

+ 0
- 8
setup.py View File

@@ -16,14 +16,6 @@
# THIS FILE IS MANAGED BY THE GLOBAL REQUIREMENTS REPO - DO NOT EDIT
import setuptools

# In python < 2.7.4, a lazy loading of package `pbr` will break
# setuptools if some other modules registered functions in `atexit`.
# solution from: http://bugs.python.org/issue15881#msg170215
try:
import multiprocessing # noqa
except ImportError:
pass

setuptools.setup(
setup_requires=['pbr>=2.0.0'],
pbr=True)

Loading…
Cancel
Save