Browse Source

Fixing the deprecated library function.

os.popen() is deprecated since version 2.6. Resolved with use of
subprocess module.

Change-Id: I2ff32c4dc37c543696125ac755dc4adb69ddacdf
Partial-Bug: #1529836
changes/51/262551/3
Harshada Mangesh Kakad 6 years ago
parent
commit
4fe1864351
  1. 8
      doc/source/conf.py

8
doc/source/conf.py

@ -28,6 +28,7 @@
# serve to show the default.
import os
import subprocess
import sys
# If extensions (or modules to document with autodoc) are in another directory,
@ -157,8 +158,11 @@ modindex_common_prefix = ['neutron.']
# If not '', a 'Last updated on:' timestamp is inserted at every page bottom,
# using the given strftime format.
#html_last_updated_fmt = '%b %d, %Y'
git_cmd = "git log --pretty=format:'%ad, commit %h' --date=local -n1"
html_last_updated_fmt = os.popen(git_cmd).read()
git_cmd = ["git", "log", "--pretty=format:'%ad, commit %h'", "--date=local -",
"n1"]
html_last_updated_fmt = subprocess.Popen(git_cmd,
stdout=subprocess.PIPE).\
communicate()[0]
# If true, SmartyPants will be used to convert quotes and dashes to
# typographically correct entities.

Loading…
Cancel
Save