Browse Source

Install "pyroute2" as a doc job depedency

By adding this library to the doc requirements file, tox will install
it limiting the upper version according to
"requirements/upper-constraints.txt".

"pyroute2" is called in tox doc job as mentioned in [1]. Since version
0.6.0, the library structure changed. To keep backwards compatibility,
all modules are imported from the main namespace. As reported in the
referred bug, the library "mitogen" must be installed first.

In stable releases that use older "pyroute2" versions, this library is
not needed but this patch should enforce the upper library version.

Related-Bug: #1928913

[1]2a4074918c/doc/source/conf.py (L33-L40)

Change-Id: I0cf458f4532d313e593a943653e8310b93ac1e9c
(cherry picked from commit 9e6b7a2284)
changes/83/792183/1
Rodolfo Alonso Hernandez 4 weeks ago
parent
commit
c9a100db20
1 changed files with 3 additions and 0 deletions
  1. +3
    -0
      doc/requirements.txt

+ 3
- 0
doc/requirements.txt View File

@ -6,3 +6,6 @@ sphinx_feature_classification>=1.0.0 # Apache-2.0
openstackdocstheme>=2.2.1 # Apache-2.0
oslotest>=3.2.0 # Apache-2.0
reno>=3.1.0 # Apache-2.0
# NOTE(ralonsoh): pyroute2 module should be installed and the version limited
# according to upper-constraints.txt
pyroute2>=0.5.13;sys_platform!='win32' # Apache-2.0 (+ dual licensed GPL2)

Loading…
Cancel
Save