Browse Source

Merge "Add requirements for jobboard drivers"

changes/19/751119/1
Zuul 1 year ago
committed by Gerrit Code Review
parent
commit
f306ec7f46
  1. 8
      devstack/plugin.sh
  2. 2
      doc/source/install/install-amphorav2.rst
  3. 3
      lower-constraints.txt
  4. 9
      setup.cfg

8
devstack/plugin.sh

@ -9,7 +9,11 @@ set -ex
GET_PIP_CACHE_LOCATION=/opt/stack/cache/files/get-pip.py
function octavia_install {
setup_develop $OCTAVIA_DIR
if [[ ${OCTAVIA_ENABLE_AMPHORAV2_JOBBOARD} == True ]]; then
setup_develop $OCTAVIA_DIR redis
else
setup_develop $OCTAVIA_DIR
fi
if [ $OCTAVIA_NODE == 'main' ] || [ $OCTAVIA_NODE == 'standalone' ] ; then
if ! [ "$DISABLE_AMP_IMAGE_BUILD" == 'True' ]; then
if [[ ${DISTRO} =~ (rhel|centos) ]]; then
@ -250,7 +254,6 @@ function install_redis {
start_service redis
pip_install_gr redis
}
function uninstall_redis {
@ -264,7 +267,6 @@ function uninstall_redis {
stop_service redis
pip_unistall redis
}
function octavia_configure {

2
doc/source/install/install-amphorav2.rst

@ -28,6 +28,8 @@ Also to monitor progress on taskflow jobs amphorav2 provider uses
jobboard. As jobboard backend could be used Redis or Zookeeper key-value
storages. Operator should chose the one that is more preferable for specific
cloud. The default is Redis.
Key-values storage clients should be install with extras [zookeeper] or [redis]
during installation of octavia packages.
1. Create the database, complete these steps:

3
lower-constraints.txt

@ -54,6 +54,7 @@ jmespath==0.9.3
jsonpatch==1.21
jsonpointer==2.0
jsonschema==3.2.0
kazoo==2.6.0
keystoneauth1==3.4.0
keystonemiddleware==4.17.0
kombu==4.1.0
@ -129,6 +130,7 @@ python-novaclient==9.1.0
python-subunit==1.0.0
pytz==2018.3
PyYAML==3.12
redis==2.10.0
repoze.lru==0.7
requests==2.14.2
requests-mock==1.2.0
@ -172,4 +174,5 @@ WebTest==2.0.29
Werkzeug==0.14.1
wrapt==1.10.11
WSME==0.8.0
zake==0.1.6
python-cinderclient==3.3.0

9
setup.cfg

@ -106,3 +106,12 @@ oslo.policy.enforcer =
octavia = octavia.common.policy:get_no_context_enforcer
oslo.middleware.healthcheck =
octavia_db_check = octavia.api.healthcheck.healthcheck_plugins:OctaviaDBHealthcheck
[extras]
# Required in case of AmphoraV2 redis jobboard is used
redis =
redis>=2.10.0
# Required in case of AmphoraV2 zookeeper jobboard is used
zookeeper =
kazoo>=2.6.0 # Apache-2.0
zake>=0.1.6 # Apache-2.0
Loading…
Cancel
Save