Browse Source

Add futures as a requirement for Python 2

[1] added futures as a requirement for Python 2, but did not include
it as part of the requirements.txt and lower-requirements.txt files.

[1]- https://review.openstack.org/593556

Change-Id: I741f406ac348a09dc0ea08396a1f7242652fde6f
Javier Pena 4 months ago
parent
commit
a25a652d89
2 changed files with 2 additions and 0 deletions
  1. 1
    0
      lower-constraints.txt
  2. 1
    0
      requirements.txt

+ 1
- 0
lower-constraints.txt View File

@@ -11,6 +11,7 @@ eventlet==0.18.2
11 11
 extras==1.0.0
12 12
 fixtures==3.0.0
13 13
 flake8==2.5.5
14
+futures==3.1.1;python_version=='2.7' or python_version=='2.6' # PSF
14 15
 gitdb==0.6.4
15 16
 GitPython==1.0.1
16 17
 greenlet==0.4.10

+ 1
- 0
requirements.txt View File

@@ -11,3 +11,4 @@ cffi>=1.7.0 # MIT
11 11
 eventlet!=0.18.3,!=0.20.1,>=0.18.2 # MIT
12 12
 greenlet>=0.4.10 # MIT
13 13
 msgpack>=0.5.0 # Apache-2.0
14
+futures>=3.1.1;python_version=='2.7' or python_version=='2.6' # PSF

Loading…
Cancel
Save