Browse Source

Update hacking for Python3

The repo is Python 3 now, so update hacking to version 3.0 which
supports Python 3.

Ignore W504 line break after binary operator

Change-Id: Ice5627d714bad308bcf2e467a553d2d2297ea337
tags/1.0.1^0
Andreas Jaeger 3 months ago
committed by Andreas Jaeger
parent
commit
b93610d0e3
2 changed files with 2 additions and 2 deletions
  1. +1
    -1
      test-requirements.txt
  2. +1
    -1
      tox.ini

+ 1
- 1
test-requirements.txt View File

@@ -2,6 +2,6 @@
# of appearance. Changing the order has an impact on the overall integration
# process, which may cause wedges in the gate later.

hacking<0.11,>=0.10.0
hacking>=3.0,<3.1.0 # Apache-2.0
oslotest>=1.5.1
stestr>=2.0.0

+ 1
- 1
tox.ini View File

@@ -66,7 +66,7 @@ commands =
# E123, E125 skipped as they are invalid PEP-8.

show-source = True
ignore = E123,E125
ignore = E123,E125,W504
builtins = _
exclude=.venv,.git,.tox,dist,doc,releasenotes,*lib/python*,*egg,build



Loading…
Cancel
Save