Browse Source

Use puppet 4 compatible mysql functions

These was introduced in 6.0.0 and is required to
support later version of puppetlabs-mysql.

Change-Id: Ibec58311585315e8ec4f748ec26b5fc2dba78a67
changes/81/635781/1
Tobias Urdin 3 years ago
parent
commit
2727fa248d
  1. 2
      manifests/db/mysql.pp
  2. 4
      metadata.json
  3. 4
      releasenotes/notes/puppet4-mysql-func-19d33ccd49701b0d.yaml

2
manifests/db/mysql.pp

@ -48,7 +48,7 @@ class ceilometer::db::mysql(
::openstacklib::db::mysql { 'ceilometer':
user => $user,
password_hash => mysql_password($password),
password_hash => mysql::password($password),
dbname => $dbname,
host => $host,
charset => $charset,

4
metadata.json

@ -13,6 +13,10 @@
"name": "puppetlabs/rabbitmq",
"version_requirement": ">=8.4.0 <9.0.0"
},
{
"name": "puppetlabs/mysql",
"version_requirement": ">=6.0.0 <9.0.0"
},
{
"name": "openstack/keystone",
"version_requirement": ">=14.2.0 <15.0.0"

4
releasenotes/notes/puppet4-mysql-func-19d33ccd49701b0d.yaml

@ -0,0 +1,4 @@
---
upgrade:
- |
This module now requires a puppetlabs-mysql version >= 6.0.0
Loading…
Cancel
Save