Remove deprecated amqp_allow_insecure_clients

... because it was deprecated during Wallaby cycle.

Change-Id: Id1aa5f3df8dd565c81ff4fda0f9bbd07faa9c7b5
changes/06/828306/2
Takashi Kajinami 1 year ago
parent cd9bf2b473
commit 41b1408e48

@ -240,12 +240,6 @@
# (optional) Topics for the versioned notifications issued by Ironic
# Defaults to $::os_service_default
#
# DEPRECATED PARAMETERS
#
# [*amqp_allow_insecure_clients*]
# (Optional) Accept clients using either SSL or plain TCP
# Defaults to undef.
#
class ironic (
$enabled = true,
$package_ensure = 'present',
@ -294,19 +288,12 @@ class ironic (
$notification_topics = $::os_service_default,
$notification_level = $::os_service_default,
$versioned_notifications_topics = $::os_service_default,
# DEPRECATED PARAMETERS
$amqp_allow_insecure_clients = undef,
) {
include ironic::deps
include ironic::db
include ironic::params
if $amqp_allow_insecure_clients != undef {
warning('The amqp_allow_insecure_clients parameter is deprecated and \
will be removed in a future relese.')
}
include ironic::glance
include ironic::neutron

@ -0,0 +1,4 @@
---
upgrade:
- |
The ``ironic::amqp_allow_insecure_clients`` parameter has been removed.
Loading…
Cancel
Save