Browse Source

Fix unit tests incompatible with puppetlab-stdlib 8.0.0

Since puppetlabs-stdlib 8.0.0, ensure_packages automatically translates
'ensure => present'  to 'ensure => installed' and that translation
breaks existing assertions in unit tests.

Change-Id: I35500af08e39725bab61be036f780c74e38313b9
changes/15/810715/2
Takashi Kajinami 1 month ago
parent
commit
a5cb8965d5
  1. 4
      spec/classes/openstacklib_openstackclient_spec.rb

4
spec/classes/openstacklib_openstackclient_spec.rb

@ -4,7 +4,7 @@ describe 'openstacklib::openstackclient' do
shared_examples_for 'openstacklib::openstackclient' do
context 'with default params' do
it { should contain_package(platform_params[:openstackclient_package_name]).with(
:ensure => 'present',
:ensure => 'installed',
:tag => 'openstack'
)}
end
@ -17,7 +17,7 @@ describe 'openstacklib::openstackclient' do
end
it { should contain_package('my-openstackclient').with(
:ensure => 'present',
:ensure => 'installed',
:tag => 'openstack'
)}
end

Loading…
Cancel
Save