Browse Source

Cleanup py27 support

Make a few cleanups:
- Remove python 2.7 stanza from setup.py
- Add requires on python >= 3.6 to setup.cfg so that pypi and pip
  know about the requirement
- Remove section from setup.cfg: Wheel is not needed for python
  3 only repo
- Update requirements, no need for python_version anymore

Change-Id: I8825104cffa158cb0423e648067fae6ad0a0711d
tags/2.0.1^0
Andreas Jaeger 3 months ago
parent
commit
a6f331e48d
3 changed files with 2 additions and 14 deletions
  1. +1
    -2
      doc/requirements.txt
  2. +1
    -3
      setup.cfg
  3. +0
    -9
      setup.py

+ 1
- 2
doc/requirements.txt View File

@@ -2,6 +2,5 @@
# of appearance. Changing the order has an impact on the overall integration
# process, which may cause wedges in the gate later.

sphinx>=1.8.0,<2.0.0;python_version=='2.7' # BSD
sphinx>=1.8.0,!=2.1.0;python_version>='3.4' # BSD
sphinx>=1.8.0,!=2.1.0 # BSD
openstackdocstheme>=1.20.0 # Apache-2.0

+ 1
- 3
setup.cfg View File

@@ -6,6 +6,7 @@ description-file =
author = OpenStack
author-email = openstack-discuss@lists.openstack.org
home-page = https://docs.openstack.org/python-aodhclient/latest/
python-requires = >=3.6
classifier =
Environment :: OpenStack
Intended Audience :: Information Technology
@@ -70,6 +71,3 @@ input_file = aodhclient/locale/aodhclient.pot
keywords = _ gettext ngettext l_ lazy_gettext
mapping_file = babel.cfg
output_file = aodhclient/locale/aodhclient.pot

[wheel]
universal = 1

+ 0
- 9
setup.py View File

@@ -13,17 +13,8 @@
# See the License for the specific language governing permissions and
# limitations under the License.

# THIS FILE IS MANAGED BY THE GLOBAL REQUIREMENTS REPO - DO NOT EDIT
import setuptools

# In python < 2.7.4, a lazy loading of package `pbr` will break
# setuptools if some other modules registered functions in `atexit`.
# solution from: http://bugs.python.org/issue15881#msg170215
try:
import multiprocessing # noqa
except ImportError:
pass

setuptools.setup(
setup_requires=['pbr'],
pbr=True)

Loading…
Cancel
Save