Upgrade pylint&astroid to a version that works with python3.7

1. Astroid and pylint are tightly coupled,so both versions should be specified for python3.7

2. A few rules are added to the ignore list in .pylintrc

Change-Id: Ice65c8fa94a2de2c0365ec5ab710d93675aacbb9
changes/38/691838/1
caihui 3 years ago
parent de0f67c6f5
commit a9258e12f6

@ -44,8 +44,7 @@ symbols=no
# --enable=similarities". If you want to run only the classes checker, but have
# no Warning level messages displayed, use"--disable=all --enable=classes
# --disable=W"
disable=W,C,R,no-member
disable=W,C,R,no-member,assignment-from-no-return,assignment-from-none
[REPORTS]

@ -1,5 +1,5 @@
alabaster==0.7.10
astroid==1.3.8
astroid==1.6.5
Babel==2.3.4
cliff==2.8.0
cmd2==0.8.0

@ -5,6 +5,10 @@ flake8<2.6.0,>=2.5.4 # MIT
hacking!=0.13.0,<0.14,>=0.12.0 # Apache-2.0
coverage!=4.4,>=4.0 # Apache-2.0
mock>=2.0.0 # BSD
pylint==1.9.2 # GPLv2
#pylint==1.9.2 # GPLv2
stestr>=2.0.0 # Apache-2.0
testtools>=2.2.0 # MIT
astroid==1.6.5;python_version<"3.0" # LGPLv2.1
astroid==2.1.0;python_version>="3.0" # LGPLv2.1
pylint==1.9.2;python_version<"3.0" # GPLv2
pylint==2.2.0;python_version>="3.0" # GPLv2

Loading…
Cancel
Save