Browse Source

Fix lower constraints

This patch updates lower-constraints.txt to eliminate contradictions.

keystoneauth1 lower constraint has to be bumped in requirements.txt as
another dependency, openstacksdk 0.15.0 depends on keystoneauth1>=3.8.0

dogpile.cache version bumped to 0.6.5 as older version had 'async' as
variable name which gives SyntaxError from py37.

Change-Id: I31464518cb7f76c0fa5275a4ef52b2a6b634cfa3
changes/17/781617/3
Elod Illes 4 months ago
parent
commit
d87683b59b
  1. 22
      lower-constraints.txt
  2. 2
      requirements.txt

22
lower-constraints.txt

@ -14,18 +14,18 @@ debtcollector==1.2.0
decorator==3.4.0
deprecation==1.0
docutils==0.11
dogpile.cache==0.6.2
dogpile.cache==0.6.5
dulwich==0.15.0
eventlet==0.18.2
extras==1.0.0
fasteners==0.7.0
fixtures==3.0.0
flake8-import-order==0.12
flake8==2.5.5
flake8==3.6.0
future==0.16.0
futurist==1.2.0
greenlet==0.4.10
hacking==1.1.0
hacking==3.0.1
idna==2.6
imagesize==0.7.1
iso8601==0.1.11
@ -34,21 +34,21 @@ jmespath==0.9.0
jsonpatch==1.16
jsonpointer==1.13
jsonschema==2.6.0
keystoneauth1==3.4.0
keystoneauth1==3.8.0
kombu==4.0.0
linecache2==1.0.0
MarkupSafe==1.0
mccabe==0.2.1
mccabe==0.6.0
monotonic==0.6
msgpack-python==0.4.0
munch==2.1.0
netaddr==0.7.18
netifaces==0.10.4
openstacksdk==0.11.2
openstacksdk==0.15.0
os-client-config==1.28.0
os-service-types==1.2.0
osc-lib==1.12.0
oslo.concurrency==3.25.0
oslo.concurrency==3.26.0
oslo.config==5.2.0
oslo.context==2.19.2
oslo.i18n==3.15.3
@ -69,9 +69,9 @@ pika==0.10.0
positional==1.2.1
prettytable==0.7.2
pyasn1==0.1.8
pycodestyle==2.3.1
pycodestyle==2.4.0
pycparser==2.18
pyflakes==0.8.1
pyflakes==2.0.0
Pygments==2.2.0
pyinotify==0.9.6
pyOpenSSL==17.1.0
@ -86,7 +86,7 @@ python-novaclient==9.1.0
python-openstackclient==3.12.0
python-subunit==1.0.0
pytz==2013.6
PyYAML==3.13
PyYAML==5.3.1
repoze.lru==0.7
requests-mock==1.2.0
requests==2.14.2
@ -97,7 +97,7 @@ simplejson==3.5.1
snowballstemmer==1.2.1
statsd==3.2.1
stestr==2.0.0
stevedore==1.20.0
stevedore==2.0.1
tempest==17.1.0
tenacity==3.2.1
testscenarios==0.4

2
requirements.txt

@ -12,7 +12,7 @@ oslo.log>=3.36.0 # Apache-2.0
oslo.serialization!=2.19.1,>=2.18.0 # Apache-2.0
oslo.utils>=3.33.0 # Apache-2.0
os-client-config>=1.28.0 # Apache-2.0
keystoneauth1>=3.4.0 # Apache-2.0
keystoneauth1>=3.8.0 # Apache-2.0
# keystoneclient is used only by neutronclient.osc.utils
# TODO(amotoki): Drop this after osc.utils has no dependency on keystoneclient
python-keystoneclient>=3.8.0 # Apache-2.0

Loading…
Cancel
Save